Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Shadow Hearts: Covenant - FMV/MPEGs broken.
#1
...:::--- The Backstory ---:::...

Hello.

I am currently trying to play through Shadow Hearts: Covenant. The game runs well, and has the typical glitches that I've read about.

( Frozen Background during Judgement Ring use, having speedhacks on makes some enemies not appear. )

I've reached a point in the game on the second disc, where an FMV plays. (Though this did happen on the first disc as well, I ignored it.)

Somehow I fixed this on a previous version of PCSX2 by messing with my settings enough. However I haven't had such luck
this time around. I do not know the previous version I was using.

So far I've tried running the game on the following builds:

PCSX 1.4.0
pcsx2-v1.5.0-dev-2456-g0efbd283c-windows-x86 (Latest)

Here are my PC Specs:

Windows 10 Version: 10.0.17134 Build 17134
x64 based PC
AMD FX™-6300 Six-Core Processor, 3500 Mhz, 3 Core(s), 6 Logical Processor(s)
8 GB RAM
NVIDIA Geforce GTX 1050

Hope I'm not missing anything...

...:::--- The Problem ---:::...

The FPS remains the same whether the video is or isn't playing. (60 FPS unless settings are garbage. No speedhacks.)

The FMV stutters. It remains in view up until a point where it freezes. It does not go black.

The audio does not play alongside the video either.

The only solution to move past the FMV, is to hit start to skip the FMV before it plays all the way through and freezes.

I can provide a video example of what's happening if necessary.


...:::--- Attempted Fixes ---:::...

1. Change from Hardware Mode (DX11) to Software (DX11)
2. Change from Software (DX11) to OpenGL Software (DX11)
3. Disabled Subtitles in game.
4. Setting EE/IOP Clamping to Full, because it fixed issues in the previous game.
5. Going to Config > Video > HW Hacks > Preload Game Data with OpenGL HW Rendering
6. Attempted different SPU2-X Sound Plug-in settings (Figured it was more a problem with the game.)
7. Attempted several different Presets, specifically safest, to aggressive with different render options. (HW, SW, OpenGL)

8. Attempted activating every manual game fix hacks PCSX2 has to offer. (Meaningless more than likely, but I wanted to see. !!!This includes switching to
GSdx software rendering when an FMV plays!!!)

9. Checked if Automatic Gamefixes has been on the entire time.
10. Updated the version of my PCSX from 1.4.0 to 1.5 in an attempt to see if these problems were rectified in the new version, and testing nearly all the same attempts.
11. Went from using Default Hardware Device for Adapter in GSdx Plug-in Settings to using my Graphics Card
12. Tried Texture Filtering of different values in the GSdx Plug-in Settings.

I am at the end of my rope. I have absolutely no idea what to do to fix this.
Any help would be vastly appreciated, as I'd like to try and watch the cutscenes in their full glory if possible!

I've also tried looking up a lot of different search terms to try and come up with a solution to the problem that's already been established, but haven't been able to as of yet. So I figured this thread may be necessary if anyone has a similar problem in the future.

Thanks!
Reply

Sponsored links

#2
Which scene it is exactly(I have all of the cut scenes in the gallery)
While I was playing the game on my PS2(from internal hdd),the game was stuttering on some cut scenes and if I remember correctly,it was randomly freezing on one of them because of something timming related.

Did you tried increasing the EE speed or/and enabling the "Enable fast DVD" speedhack
Reply
#3
(07-28-2018, 12:27 PM)vsub Wrote: Which scene it is exactly(I have all of the cut scenes in the gallery)
While I was playing the game on my PS2(from internal hdd),the game was stuttering on some cut scenes and if I remember correctly,it was randomly freezing on one of them because of something timming related.

Did you tried increasing the EE speed or/and enabling the "Enable fast DVD" speedhack

To be specific, from Disc 1 - It was the scene after defeating Rasputin where the crew escapes by airship. As soon as the Airship hits center view, it freezes for me.

From Disc 2 - The Fountain of Sukune Scene after meeting with Saki for the first time in Inugami Village, stuttered and froze horribly. I had to skip it.

Finally, also from Disc 2 - the scene where I'm currently having trouble, is when Yuri and Roger go together into a lab to try and fulfill the Emigre Manuscript's purpose
to resurrect a fallen person.

Trying to explain without spoilers, let me know if you need more specificity. I also don't understand the context of what happened _in_ the cutscenes, because I had to skip them, but I can tell you what was happening in game surrounding them.

As for trying the EE speed or Fast DVD SpeedHack: I've tried both now. First I left the "Enable Fast CDVD" hack checked, and then went through the various increasing cycle speeds. From 100%, to 130%, to 180% to 300%, testing individually with the "Enable Fast CDVD" hack enabled. No dice! Unfortunately.

Now I'll be trying the EE Cycle Speed increase with "Enable Fast CDVD" hack off. The results are the same. The video is silent, and slowly stutters until freezing.

Thanks for your time and help!
Reply
#4
Alright. I've fixed it!

The key is changing the Sound Options in game from "Dolby Digital 5.1" to "Stereo." and now it works flawlessly.

Why does it happen? Who knows! That's the fix though in case anyone runs into this problem in the future.

Time to enjoy the game! Smile
Reply
#5
Yeah, the dolby digital 5.1 decoding is not supported yet on PCSX2 which will likely cause the FMV's that use it to stutter, it also happen in Gran Turismo 4 if you enable the dolby digital 5.1 audio in the seting tab.
Reply




Users browsing this thread: 1 Guest(s)