Thread Rating:
  • 11 Vote(s) - 4.27 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Shadow of the Colossus !!!
#51
Hello pcsx2 users.
We all know the issues of shadow of the colossus, as in: 1. the shadow bug, 2. the effect codenamed "fairy shading" missing (it does work in software mode though), and 3. motion blur missing only after enabling progressive scan.

I have found a strange way to bring the fairy shading to life in hardware mode, and to bring the motion blur back in action after enabling progressive scan. (See attached images for comparison)

You need to make a save state file INGAME, (while prog. scan is already enabled), then quit pcsx2. Run pcsx2, and choose File \\ States \\ Load \\ OTHER. Find the save state that you made earlier, run it, and voila, you have fairy shading and motion blur.

I thought this was worth posting, after all, the question is, WHY does loading a save state form the pcsx2 menu fix the bugs? Maybe there's something there that does the trick, and should be included in the plugins themselves or something...

[Image: 38515395.jpg]
[Image: 38515421.jpg]

Sponsored links

#52
I get the attach glitches, Seems they do not appear in NATIVE mode at all.

Any clues? I have tried just about everything I can think of, others get this as well and can be seen in the lower screenshot above my post too.


Attached Files Thumbnail(s)
   
#53
Prime, try different versions of the GSdx plugin.
There's comparisons here, in this very thread.
OS: Windows 7 64bit
CPU: Intel Core i7 3770K @3.5 GHz
RAM: 16GB DDR3 1600MHz
GPU: Nvidia GTX 680 2GB
#54
yeah my problem is really unrelated, its to do with the black bars and screen edge distortions .

Ell well.

PS. Seems I got rid of the issue if I don't turn on progressive scan. It only shows while inside structures and possibly related to that bloom crap also but not a major.
#55
Does anybody know someting about a pnach/patch for disabling the shadows in the game ? I've seen some pics, so there must be one somewhere...
#56
(08-15-2009, 12:02 PM)Innuendo Wrote: Does anybody know someting about a pnach/patch for disabling the shadows in the game ? I've seen some pics, so there must be one somewhere...

im wondering the same thing...in gsdx r1479 the shadows in Ico are disabled but in sotc they are present...gabe said it should be possible to turn off the messed up shadows...hopefully in a future revision he will remove them but maybe there is some pnach that can do it too?
#57
Thumbs Up 
(08-02-2009, 05:47 AM)prime2009 Wrote: I get the attach glitches, Seems they do not appear in NATIVE mode at all.

Any clues? I have tried just about everything I can think of, others get this as well and can be seen in the lower screenshot above my post too.

I've got the solution for you:

This workaround not only removes the black bars that you've shown, but also aligns the the bloom shading layer and the fairy shading layer to its rightful place.

The newest realease of gsdx ( r1560 as we speak) now supports manual pixel offset.
Download it from here: http://pcsx2.dyndns.org/index.php#GSdx
And implant it.
Now you must play around with the gsdx.ini file (in the pcsx2 ini's folder, it is.)
OPen the ini, and write these two lines to the bottom:
pixoff_x=0
pixoff_y=0

For various internal resolutions, different numbers put the layers in the right place.
I use 800x600, and pixoff_x=-7 with pixoff_y=3 were the correct settings.

See the attached pictures that show a great opportunity in the game, for checking the the best alignment. You can make a save state over there, so you can instatnly load there to check what you've done...
[Image: sotcfsh1.jpg]
[Image: sotcfsh2.jpg]
#58
Innuendo, what PCSX2 revision are you using to successfully load savestate from startup ? I tried rev.1669 but it crashes, and tried rev 945 it works (with proper shading) but this old revision is slow and without microVU =(
Excl The man will die, but not his ideas Excl
#59
(08-22-2009, 12:52 PM)Linear Wrote: Innuendo, what PCSX2 revision are you using to successfully load savestate from startup ? I tried rev.1669 but it crashes, and tried rev 945 it works (with proper shading) but this old revision is slow and without microVU =(

Yes indeed the old version pcsx2 is slow and bogus with new gsdx plugins... but what would you need MicroVU for in SOTC ? I found no use of it...

Anyway, on to the point... It took some tempering to find the way to get the Save States to work...

MY first problem was that I could not make a save state in the first palce. Pcsx2 would crash all the time I pressed F1. Than I got informed that Save Wtates work with only one PAD plugin (What the hell...), wich is Lilypad.

So then I was able to make the save state, but loading it from startup still didn't work.

Then I tried... did you notice the new "Run BIOS (No Disc) option in the Fie menu ? I tried starting that , then quitting quickly, and loading the state from the menu then. Results were the "Almost but not quite" kind... The game loaded and the shadings and motion blur worked, BUT the DVD plugin was just not loaded because of the "No Disc" mode.

Another attempt... Trying to use the Run/Execute OPtion to start the BIOS, then quitting and loading the state. FAILIURE. With this way, for some reason, the shadings and the motion blur DOES NOT get to work. And that would have been the whole point, wouldn't it...

And finally the solution... You have to choose another game's ISO to begin with (Linuz ISO plugin, naturally!). I chose god of war's iso for instance...
Now Run/Execute. The Bios should begin to start up, but don't let it, hit Esc quickly. Now change the ISO file the SOTC, and load your Save State form the menu. (You have to use the File/States/Load/OTHER option).

I cannot assume anything else then it is pcsx2 disabling the shadings for the game's CRC. And with this workaround we are fooling it to thinking it is playing another CRC...
#60
Ma-a-an, you did a hell-of-a-job !!! But can you tell me you pcsx2 rev. number ? Newest revisions gives a cdvd crash if I trying to load savestate Sad
So I'am searching most stable revision. MicroVU is faster and gives smooth framerate Smile And I discover interesting framerate config option : Set VU stealing to the middle level (level 2), turn on EErec sync speedhack to 1,5 (never use x2 sync hack) and you will notice that framerate is more smooth, without burst frameskipping. And if you have Core i7 you can even set Default EE sync to x1 (smooth and perfect gameplay). Hope it is usefull to you.
Excl The man will die, but not his ideas Excl




Users browsing this thread: 1 Guest(s)