Shadow of the Colossus optimal settings
#1
I'd like to run this game at the best of my possibilities. Probably the game already runs better than on an actual PS2, but it still suffers from slowdowns, and unfortunately all the tutorials I can find are pretty old.

Also, is there a way to run the game at 60FPS?

Specs:
CPU: Intel Xeon E3-1231 V3
GPU: RTX 3060
RAM: 16GB DDR3 1600 in dual channel (XMP 1.3)
Storage: I'm running the game from an SMB share (gigabit wired LAN), and it physically resides on a mechanical WD green. I'm not sure if this can have some impact on the performances.
PCSX2: Nightly - v1.7.4137

Settings:

BIOS:
USA SCPH39001.bin (the ISO is PAL, but I'm selecting NTSC mode at the start menu)

Emulation:

Enable Speed Limiter: yes

Enable Instant V1: yes

Maximum Frame Latency= 2 frames

Optimal Frame Pacing: no

Scale To Host Refresh Rate: no (I have a freesync/G-Sync monitor)

EE Cycles Rate: 130% (it makes the game a little faster and smoother, while 180% makes it slower and choppier. CPU limitation?)

EE Cycle Skipping: Disabled  (Mild Underclock makes the game slower, despite the fact that the setting's description explicitly mentions improvements in SOTC if selected)

Affinity Control: disabled


Graphics:

Rendering:

Everything default except 6X native resolution (I also tried 3X but it runs faster in 6X. CPU limit again?)

Post-Processing:

Everything default except TV Shader: Scanline filter

Everything else is default.



Any suggestions?
Reply

Sponsored links

#2
(02-25-2023, 01:37 PM)Mitsukuni Mito Wrote: I'd like to run this game at the best of my possibilities. Probably the game already runs better than on an actual PS2, but it still suffers from slowdowns, and unfortunately all the tutorials I can find are pretty old.

Also, is there a way to run the game at 60FPS?

Specs:
CPU: Intel Xeon E3-1231 V3
GPU: RTX 3060
RAM: 16GB DDR3 1600 in dual channel (XMP 1.3)
Storage: I'm running the game from an SMB share (gigabit wired LAN), and it physically resides on a mechanical WD green. I'm not sure if this can have some impact on the performances.
PCSX2: Nightly - v1.7.4137

Settings:

BIOS:
USA SCPH39001.bin (the ISO is PAL, but I'm selecting NTSC mode at the start menu)

Emulation:

Enable Speed Limiter: yes

Enable Instant V1: yes

Maximum Frame Latency= 2 frames

Optimal Frame Pacing: no

Scale To Host Refresh Rate: no (I have a freesync/G-Sync monitor)

EE Cycles Rate: 130% (it makes the game a little faster and smoother, while 180% makes it slower and choppier. CPU limitation?)

EE Cycle Skipping: Disabled  (Mild Underclock makes the game slower, despite the fact that the setting's description explicitly mentions improvements in SOTC if selected)

Affinity Control: disabled


Graphics:

Rendering:

Everything default except 6X native resolution (I also tried 3X but it runs faster in 6X. CPU limit again?)

Post-Processing:

Everything default except TV Shader: Scanline filter

Everything else is default.



Any suggestions?

I'm playing Need for Speed Most Wanted at 1080p but with 50 fps because something very strange happens on my laptop if I try to run at 60 fps (A lot of stutterings).

I have a Intel i7-11850H and a NVIDIA T1200 (similar GTX1650) - It's a Dell Precision (mobile) workstation...

I'm using DX12 with "V-Sync" activated and "Optimal Frame Pacing" + "Scale to Host Refresh Rate".

The only solution for me (maybe also for you):

1) Disable the "Enable Speed Limiter" on PCSX2 (the game will run at Maximum speed but it's unplayable ... you will need to "lock" the FPS);
2) On the top menu, select Tools and activate "Show advanced settings" (it will present a screen saying that this is something not usual);
3) Right click on the game that you wanna change and open the "Properties" (by doing this you will change only the FPS for THIS game);
4) Open the Setting and navigate to the "Advanced" menu, change the "Frame Rate Control" to a fixed FPS, in my case 50 FPS (below my screen refresh 60 Hz).
5) Use a external software to "lock" the FPS ... in my case 50 FPS (I'm using MSI Afterburner)

After that I could play with a solid/stable "Frame Time" of 20 ms (50 FPS) without suffering with stutterings anymore.

I tried all the possible configurations before that and this was the only thing that solved my problem.

In my case it was 50 FPS because of my GPU and CPU. You have a RTX 3060 ... probably you will be able to "lock" using a higher FPS number.

Good luck!!!
Reply
#3
(03-08-2023, 05:20 AM)Vicinius Wrote: I'm playing Need for Speed Most Wanted at 1080p [...]

I tried your suggestion: the game runs silky smooth at 60... in open areas where not much is going on. But as soon as an arena or a new complex area loads the frame rate drops (but then goes up again). It's most likely a hardware problem, my CPU is pretty old at this point. However, with your settings the game seems to run better overall, thanks.
Reply
#4
Basically, pushing vu cycle stealing a notch should be enough
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Reply
#5
I've found that there has been a significant performance regression in SOTC going from 1.7.2 to 1.7.3 with all usage statistics (VU and EE in particular) going from mid 50% in the most demanding area (the lake and platform by the third boss) up to pegged 100% usage on all stats. This seems to have been mostly remedied as of 1.7.5060 so I would suggest updating to the newest nightly build.

However performance still seems to be better on the older versions, on 1.7.24 Ive had the best performance however there is an issue with spirte alignment at higher resolution, a mixture of aggressive/special half pixel offset and 100,100 texture offset helps this but the texture offset also causes issues with bloom so its a balancing act

Regardless of the build SOTC is very intensive on the Emotion Engine so having a strong single thread cpu will be very important for this game, you have quite an old xeon cpu so it may be that the game just wont run so well on your setup. I would try the new nightly build with 130% cycle rate and vulkan API, load a save with only the first two bosses killed and stand by the lake in my screenshots where the third boss is, the sprite for this boss adds quite a lot to EE usage, if youre keeping 60fps try the fight, this is the most performance intense part of the game. Compare this between the newest nightly build and the 1.7.2 build (you can adjust VU cycling in this older build) and find which seems to perform best

I've attached screenshots of the performance regression between 1.7.2412 and 1.7.3102 which might be useful for future reference if performance regresses again


Attached Files Thumbnail(s)
       
Reply




Users browsing this thread: 3 Guest(s)