Shin Megami Tensei: Digital Devil Saga shadow glitch

Windows 8.1 64-bit
8 GB Ram
i7-4770 CPU @ 3.40GHz
Nvidia GTX 660 1.5 GB Vram
I'm using the release version of pcsx2 1.2.1

Are there any settings besides running in software mode that don't show cast shadows glitched? I don't have that much experience with the advanced settings so I don't know if this is the sort of thing that can be worked around. I've only really changed the scaling, added the extra rendering threads, and the multithreaded microVU1. I'm using either directX9 hardware or software.

I really like how the game looks scaled up in hardware mode but the shadows really bother me so I've been using software mode.

thanks Laugh

Sponsored links

Don't know how it looks like but if there is a solution it is probably in the HW-hacks section in gsdx-plugin configuration. First you have to tick the tickbox "Enable HW Hacks" and then click on configure.

You can either play with skipdraw 1-10 and see if it solved the problem.
Or if it is an upscaling problem those tc offsets might help. I think the range for x and y is between 0 and 1000 so you can test combinations like (0,0), (500,0) (1000,0), (1000,500) and so on. Just see if that setting could solve your problem.
You might also test wild arms offset in one of its options.

If you find a solution or not it would be nice if you update the wiki with your experiences.
Seems like quite a lot of games have shadow issues.
Thanks for the ideas Smile . I tried the settings that willkuer suggested and I also tried running in native res and using dx11. I didn't have any luck though.

Here are some pictures of this problem for reference. It looks like the cast shadow is being drawn over the model. It might be a post processing bug since thats what I've had to work around with software mode before.


Users browsing this thread: 1 Guest(s)