Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Silent Hill 2 Control Issues- Cannot Access Inventory/ Self-Heal
#1
I am trying to play the Silent Hill 2- NTSC-U ROM, and everything is running perfectly, except for one thing. For some reason, even though the game has an inventory system, which is supposed to be accessed by either pressing Start or Up on the D-Pad, I am unable to access the inventory at all.

I am using a DualShock 4 controller, and have set the SH2 control scheme to 2-D movement. The D-Pad, instead of Up= Inventory and Right= Quick Heal, is just changing the direction the character faces.

I have looked at the controller settings in PCSX2 and I see that Start (or Options on DualShock 4) is set to be the equivalent of Escape on the keyboard. So, when I press Start/ Options, instead of opening the in-game inventory, my game closes immediately.

I have literally tried pressing every single button on my keyboard to try to determine which key controls inventory access, then simply figure out which DS4 button corresponds to the keyboard key, but not a single key opens the menu.

I also tried using a DualShock 3, but for whatever reason, it will not even turn on when connected to my PC via the USB cable. I tried downloading the libusb drivers so the DualShock 3 Native Mode option would no longer be grayed out under PCSX2's controller settings, but apparently since I am running Windows 10, I am unable to install them because when it tried to install I got an error message saying that I was unable to accept/install unsigned drivers. I did some research into turning off the signature requirement for drivers, but that is a very involved process, so if I can get by with using the DS4 instead, and just get the inventory and self-heal buttons working properly, that would be best.

Any suggestions? Thanks in advance for your help!

Sponsored links

#2
I was able to get it working properly after a bit of trial and error.

When I started looking at the keybindings under "Pad 1" I noticed that, for example, when I tried to map the "Square" button, instead of changing the existing value for "Square" it added a whole new entry for "Square" beneath the existing list of keybindings.

So, I used the "Clear All" button in "Pad 1" settings to remove all existing keybindings, so I was starting with a completely blank page. Then I mapped each individual button on my DualShock 4, hit "Apply" and "Okay" and rebooted my game. Voila! Working like a charm now. I am able to access my inventory for the first time AND my quick-heal/ D-pad buttons are working perfectly.
#3
I'm new here and wanted to add my 2 cents, I hope this will be helpful. 

I was having trouble with this as well, as I'm new to this controller.
I've just discovered the DualShock 4 controller's Touchpad has 2 built-in buttons (L & R).  The left button is to pause the game, while the right button brings up your inventory.

I'm playing SH2 on my PS4 via Playstation Now and the R button within the Touchpad is the default config' for the inventory.
If the DS4 controller is compatible with the PS2 Emulator, I'm sure it can be set up this way. Smile
#4
The most recent post in this thread is more than 8 months old. Please create a new thread and refrain from posting in threads older than 8 months in the future. Please also review the forum rules. Thank you.
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go




Users browsing this thread: 1 Guest(s)