Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Silent Hill 2 Graphical Issues
#1
Just started using PCSX2 the other week, and I haven't had any major issues with games I've tried on it, until now...

So, I've been getting some graphical glitching, it seems. And while I would normally be fine with that (like with Ape Escape 2 where the textures bug out occasionally), this is a bit of a larger problem. I took a screenshot to illustrate the issue.

[Image: silenthill2.png]

So, whenever I start the game up I get this grey square of static that doesn't do anything. It just covers up a quarter of the screen. This could be a problem, because not only do I want to see all of the screen, but it's a major blind spot, which is not good in Silent Hill. At all.

I tried it using the latest revision, first, and I got the grey square. Also, when I opened the menu I couldn't see anything, and the graphics bugged out. I looked up some Silent Hill 2 support and it said to use an older revision of PCSX2, so now I'm using one from September of 2011 (the folder on my desktop is called 'pcsx2-4918-windows-x86'). It fixed the menu issue, although there's another minor graphical bug that doesn't bother me as much (I'll mention it later).

So, to give some information, everything's at its default settings. I have Direct3D9 (Hardware) for the renderer, which seems to work best. The only change I made is that I set frameskipping to 2 frames to draw/skip, which I always use. Everything else is defaulted.

That other minor bug I mentioned is that when I press select I get a gray screen until I press select again. I have no idea if that button does anything in Silent Hill 2, so it might be insignificant. And when I press triangle I get a gray screen for a second or two until it says something like 'I don't have the map for this area'. So, like I said, it may be insignificant. I don't know.

Here are some specs (gotten from the PCSX2 log). I don't think they matter with graphical glitching issues, but what do I know?

Quote:Host Machine Init:
Operating System = Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit
Physical RAM = 6004 MB
CPU name = Intel® Core™ i5 CPU M 460 @ 2.53GHz
Vendor/Model = GenuineIntel (stepping 05)
CPU speed = 2.526 ghz (4 logical threads)
x86PType = Standard OEM
x86Flags = bfebfbff 009ae3bd
x86EFlags = 28100000

The point of all this being, does anyone have any ideas on if this is fixable or suggestions on what to try? I guess I can play Silent Hill 2 like this if I absolutely have to, but like I said, that blind spot is going to be nothing but trouble if I have to. Everything else runs smoothly as far as I can tell. I get a solid 40 fps, the fmv's look good and have no graphical issues, and the game looks good other than that.

Thanks in advance for any suggestions or advice. Oh, and obviously, if you need some information I haven't listed here, just ask. I'm new to this whole thing, so I don't exactly know what information you do/don't need in all this.

Edit: Yeah, this might be a bigger problem than I thought. I get that grey screen and some graphical glitching when transferring between areas, too, and when I went outside of the starting area I saw this.

[Image: silenthill22.png]

I'm definitely going to need some help, here.
Reply

Sponsored links

#2
What GPU do you have?
Have you tried disabling the frame skipping?
You have the problem also in software mode?
Ryzen 7 [email protected](up to)4.0GHz | Noctua NH-D14| Asrock X370 Gaming K4| Sapphire R9 270X 2GB| 2*8GB Corsair LPX 3000MHz [email protected] C14| Samsung 840EVO 250GB| Seagate Barracuda 7200.12 500GB| WD Caviar Green 2TB| Seagate Barracuda 7200.14 2TB| Samsung S24B300 + Samsung S24D300 + Samsung S24F250| NZXT Phantom 410| Enermax Revo'Xt 730W| Gigabyte M6900
Reply
#3
No freaking way.

Disabling frame skipping made it work perfectly. The FMV kind of freaks out, but everything outside of the FMV's works perfectly, now. Literally, perfectly. Not even one frame of glitching when pausing or pressing the triangle button as far as I can see. I can't believe that was the solution. I had no idea that kind of thing would have any bearing on it.

Thanks a lot. I'm going to be playing Silent Hill 3 and 4 on PCSX2, as well, so I'll take this lesson to heart. It did hurt the FPS, turning off frameskipping. It's steadying around a stable 30 fps. I have a more powerful computer in my home (far more powerful than the laptop I'm using PCSX2 on) so I think I can try it out on there, and that might bring it back up a little. But even if that doesn't work, I don't care. 30 fps is fine with me, and I'm just glad, now that it works like it should.

So, thanks for asking if I disabled frameskipping. Apparently, that's all I needed. Tongue
Reply
#4
You're welcome. Anyway if you look in the description of frame skipping it sais that it doesn't work perfectly and can cause graphical issues.
To improve the FPS you can try lowering the resolution, even at something lower than native, you'll lose graphical quality but you'll get more FPS if the problem is the GPU, otherwise you should try some speedhack.
Ryzen 7 [email protected](up to)4.0GHz | Noctua NH-D14| Asrock X370 Gaming K4| Sapphire R9 270X 2GB| 2*8GB Corsair LPX 3000MHz [email protected] C14| Samsung 840EVO 250GB| Seagate Barracuda 7200.12 500GB| WD Caviar Green 2TB| Seagate Barracuda 7200.14 2TB| Samsung S24B300 + Samsung S24D300 + Samsung S24F250| NZXT Phantom 410| Enermax Revo'Xt 730W| Gigabyte M6900
Reply
#5
Thx PCSX2 team, the game works perfect here and looks beautiful at 4X internal resolution (GSDX DX11). Mi PC is really basic, Phenom II X4 @ 4.1 Ghz, Radeon HD 5770 Hawk 1 GB, 4 GB RAM. Im using PCSX2 1.0 svn 5460. PAL game.

[Image: 53be7813be1c476821d7388cfd6ade30o.png]
[Image: 0559935bf7699a28d187f03c6abcd593o.png]
[Image: fcc8940696bfa129eeea6ced1f08c93do.png]
[Image: 4be3318c85ad4616f5ec9d1875c820b1o.png]
[Image: 5055b58a398552fc568e799a62c1f4a2o.jpg]
Reply




Users browsing this thread: 1 Guest(s)