Silent Hill 2 keeps crashing.
The game usually crashes as soon as you enter the streets at the beginning. Using latest svn release. Can someone fix this?

Sponsored links

post the emulog.txt, please
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
I can confirm this problem as well, i dont know if the emulog would help since the game just freezes instead of crashing, you walk into the street, and if you go left the game keeps working, but as soon as you even intend to go right, where the rest of the town is, the game stays there, music and sound goes on, you cant hear footsteps anymore though so the the game itself isnt working not just the graphics.

The log doesnt display anything when it happens, the FPS counter in the game window and other data still registers as if you were playing.

Pressing Escape closes the window fine with no hang ups or delays, but if you bring it back up by resuming the music and ambient sound continues except screen is completely black.

Im using the NTSC version, if someone has any idea about what could it be i'd be happy to try and test the game further.
I can confirm the PAL director's cut version also crashes. Same spot, except the whole emu now crashes, not just the game.
No problem here with PCSX2 5443.

Silent Hill 2 SLUS 20228.
Well Dr. if the whole emu crahes for you maybe the emulog displays some clue about whats going on, so try to post it.

Also, Azazel, you have the regular version of silent hill 2?, not restless dreams? i think for ps2 its called greatest hits, at least thats what it says in wikipedia.
I tried my two version of Silent Hill 2.

- Silent Hill 2 regular version NTSC US ==> SLUS 20228

No problem at all.

- Silent Hill 2 Director's Cut version PAL ==> SLES 51156

No problem at all.

On PCSX2 svn 5443. I have been until the first fight in the town. it's good ?
But the point is, it crashes on the latest svn. So along the way, someone broke it.
I just tried last PCSX2 SVN and indeed my two games crash now :-/

Another bug that i found, on last SVN ==> Fences don't have textures properly.

Screenshot below for show this bug.

PCSX2 svn 5443 :

[Image: f4984ad41404a821163325d9f2bc8tt.jpg]

PCSX2 SVN 5460 :

[Image: 6be7f82bb8dba3513e7e673bdeba9tt.jpg]

Same config on both.

Bug occurs between PCSX 5443 and PCSX2 5457.

PS : Sorry for my english Tongue2
Okay Azazel, my game is working past where it used to crash, now with 5443.

Thanks for letting us know, i can play the game now, i hope they re-fix the game in the newer revs

Users browsing this thread: 1 Guest(s)