Silent Hill 2 trouble
Using 1.2.1.r5873

Having a problem where, when starting a new game of SH2, the opening FMV is skipped and then I can't leave the starting room.

It's like the game isn't loading the "door" to the next area, so the little hall that should lead outside just keeps me trapped.

I've played through the game flawlessly before, using an older version. Tried running the game with the latest 1.3.0 revision and nothing changed.

Any tips?

Sponsored links

under emulation settings put your clamps to full
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Tried setting it to full under EE/IOP and then also setting VUs Clamping to Extra+.
No change.

I've also tried a couple of basic things, like setting the preset to safest and repacking the .iso to no avail.
You've tried to run in software mode (F9)?
Yes, I tried having it in software mode before starting a new game. No difference there, either.

The log isn't throwing any errors at me. I think I'm going to try downloading an iso of the greatest hits version and see how that works out.
YOu can't download the game. That's piracy and we don't offer support for that
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Our forum does not tolerate any kind of warez talk / discussion / links and no support will be given as such.
Read our rules,specifically rule #1. Thread closed.
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go

Users browsing this thread: 1 Guest(s)