Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Silent Hill 3 shadows/grain [2018 edition]
#1
After some googling I see this problem is persistent for sometime now, maybe, 3 to 4 years. 

I'm trying to play the game at 4k, 3840x2160 and I don't believe this could be considered a custom resolution but a integer scaling resolution of PS2 IR. 
I'm using a 1080 Ti, and I can't test with AMD gpu, so I can't comment if this is a problem related to Nvidia drivers.

I'm aware this is part of the PCSX2 wiki, here: https://wiki.pcsx2.net/Silent_Hill_3
None of the fixes proposed on the wiki worked for me. 


Since this is an old glitch/bug, I would like to ask if this is actually fixable or not?
Reply

Sponsored links

#2
It seems like the shadow problem is fixed by using Depth Emulation, and the grain problem is fixed by setting Blending Unit Accuracy to Medium or higher. Unfortunately for you, these are both OpenGL features that either cannot or have not yet been implemented in D3D. So your best bet is to either use a software renderer and deal with the native resolution, or attempt to use OpenGL Hardware, but this will likely run poorly due to AMD's refusal to fix their OpenGL drivers.

Side note, straight up 4k resolution is NOT a multiple of the PS2's native resolution, since it is 16:9 and the PS2's was 4:3. Using a custom resolution is generally not recommended and can increase the GSdx workload to a level higher than the multiplier that gives you the equivalent resolution. For 4k, you should be able to use 6x in most games.
Problems? Check out the development builds for the latest updates.

Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070 Ti FTW2 (8 GB)
OS: Windows 10 Pro (64 bit)

Oh yeah Red Pandas are cool too.


Reply
#3
(06-04-2018, 06:31 PM)pandubz Wrote: It seems like the shadow problem is fixed by using Depth Emulation, and the grain problem is fixed by setting Blending Unit Accuracy to Medium or higher. Unfortunately for you, these are both OpenGL features that either cannot or have not yet been implemented in D3D. So your best bet is to either use a software renderer and deal with the native resolution, or attempt to use OpenGL Hardware, but this will likely run poorly due to AMD's refusal to fix their OpenGL drivers.

Not sure if I follow, I'm using a Nvidia 1080 TI, I don't own an AMD gpu.
OpenGL software is able to run on Nvidia hardware, correct?

(06-04-2018, 06:31 PM)pandubz Wrote: Side note, straight up 4k resolution is NOT a multiple of the PS2's native resolution, since it is 16:9 and the PS2's was 4:3. Using a custom resolution is generally not recommended and can increase the GSdx workload to a level higher than the multiplier that gives you the equivalent resolution. For 4k, you should be able to use 6x in most games.

So PS2 internal resolution is 640x480 (480p)? 6x would be 3840x2880?
This means the desktop will be running at 3840x2160 and the game graphics will run at 3840x2880, is that one of the problems that you say 4k is CR?
Reply
#4
(06-04-2018, 07:09 PM)veggav Wrote: Not sure if I follow, I'm using a Nvidia 1080 TI, I don't own an AMD gpu.
OpenGL software is able to run on Nvidia hardware, correct?  


So PS2 internal resolution is 640x480 (480p)? 6x would be 3840x2880?
This means the desktop will be running at 3840x2160 and the game graphics will run at 3840x2880, is that one of the problems that you say 4k is CR?

Native resolution is what you see in game window overlay upper right corner while in software mode. For exapmple THPS4 use 640 x 448, Richard Burns Rally 512 x 541. So best you can do is use default multipliers available in settings. Otherwise you need to set it manually for every game if you want use non-custom res.
Reply
#5
(06-04-2018, 07:57 PM)kozarovv Wrote: Native resolution is what you see in game window overlay upper right corner while in software mode. For exapmple THPS4 use 640 x 448, Richard Burns Rally 512 x 541. So best you can do is use default multipliers available in settings. Otherwise you need to set it manually for every game if you want use non-custom res.

So, yes, I'm not using CR. I'm using 4k as my desktop resolution but I'm using full screen with 6x multiplier here.
Reply
#6
(06-04-2018, 06:31 PM)pandubz Wrote: Using a custom resolution is generally not recommended and can increase the GSdx workload to a level higher than the multiplier that gives you the equivalent resolution.

Just to reiterate, it's better in most cases to render excess pixels then it is to render a non 4:3 resolution if I'm looking to increase performance/ reduce load on my GPU?
Reply
#7
(06-04-2018, 07:09 PM)veggav Wrote: Not sure if I follow, I'm using a Nvidia 1080 TI, I don't own an AMD gpu.
OpenGL software is able to run on Nvidia hardware, correct?  


So PS2 internal resolution is 640x480 (480p)? 6x would be 3840x2880?
This means the desktop will be running at 3840x2160 and the game graphics will run at 3840x2880, is that one of the problems that you say 4k is CR?

I'm an idiot is the problem, I saw AMD and jumped the gun. So yeah you should be able to do OpenGL Hardware no problem.

Yes the PS2 is native 640x480, which is 4:3 and 4K is 16:9. So by definition, forcing PCSX2 to true 4K will alter the aspect ratio, which causes both graphical artifacts and a much heavier workload for GSdx. Setting it to 6x does yield slightly larger than 4K, yes, but this is the internal framebuffer, remember, not the final output resolution. So that extra will get shaved off by the GS window no problem.

Edit for clarity about the original settings: Depth emulation is enabled by default for the OpenGL Hardware renderer, and all you have to do is set Blending Unit Accuracy to medium or higher. But I would recommend sticking to medium, because even high end GPUs will quickly start hitting their limits if it is turned too high.
Problems? Check out the development builds for the latest updates.

Mobo: ASUS Prime Z370-A
CPU: Intel i7-8700K (3.7 GHz)
RAM: G.Skill TridentZ, 2x8 GB DDR4 (3000 MHz)
GPU: EVGA GeForce GTX 1070 Ti FTW2 (8 GB)
OS: Windows 10 Pro (64 bit)

Oh yeah Red Pandas are cool too.


Reply




Users browsing this thread: 1 Guest(s)