Thread Rating:
  • 1 Vote(s) - 2 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Slow fps when running FFX
#1
Hi, I'm new to pcx2. Just downloaded it to play FFX, but I couldn't get pass the crawling 30fps. I'm using Core i7 740QM with ATI Radeon 5470. Is my system not suitable for pcx2 or smt?
Reply

Sponsored links

#2
Are you playing directly from the game disc, or did you make an ISO of the disc? Make it into an ISO, as this can affect speed.

The first thing to mention is that laptops often will throttle themselves, so check and make sure your Power Options are set to "High Performance".

Now, your GPU is a bit weak. Set GSdx to native res by checking the box in Config -> Video (GS) - > Plugin Settings... . This will help at times, if not imediately.

Also, look in Config -> Emulation Settings then the section labeled "Speedhacks". Go ahead and enable them, and feel free to raise the EE Cyclerate and/or VU Cycle Stealing sliders to improve speed. These may begin to cause issues/glitches when used to a certain degree (varies by game), but FFX should work fine with them, usually even when "maxed out".

BTW - Have you read the configuration guide yet? It's full of good tips. Wink
Reply
#3
Since he said downloaded, I'm guessing it's an ISO. Just a matter of time before this thread gets locked.
Reply
#4
(04-28-2011, 08:57 PM)ilovejedd Wrote: Since he said downloaded, I'm guessing it's an ISO. Just a matter of time before this thread gets locked.

(04-28-2011, 06:24 PM)mib1990 Wrote: Hi, I'm new to pcx2. Just downloaded it to play FFX, but I couldn't get pass the crawling 30fps. I'm using Core i7 740QM with ATI Radeon 5470. Is my system not suitable for pcx2 or smt?

Nah... that's pretty clear that he downloaded pcsx2 to play FFX... not the other way around.
Reply
#5
"Hi, I'm new to pcx2. Just downloaded it to play FFX."

"It" is PCSX2.
Reply
#6
Gah, sorry. For some reason, I read that as "Just downloaded FFX." Guess that's what happens when you're reading too many posts from various forums.
Reply
#7
@Ilovejedd: I downloaded pcx2, not FFX.
@Rezard: I play directly from the game disc, but the speed is still too slow. I'll try your recommendation and tell you later
Reply
#8
Just try changing the Round Mode to Nearest and Clamp to None! These might also help in giving a fps boost! Use The GSdx SkipDraw hack. It speeds up my game. Also, check that the Disable Framelimiting should be turned ON(i.e. checked).
Reply
#9
maximizing speedhacks does wonders with FFX.
Reply
#10
recoder hey thats good advice!! except when he performs his first sending at kilika and he cant get past it!! he needs everything everyone has said, but MIB1990 needs also to know this,
Set your Rounding Mode to Extra, and Extra+Preserve when your in Kilika at the first Sending!!
That way you can get to the save sphere in the hotel. Then return them to normal. or NONE, actually.
(OS:Win7_64bit ULTIMATE) (M4a88TD-M asus mobo)
[Processor:AMD AthlonII x4 645 3.720ghz(OC)Quadcore]
VideoCard-[ATIradeon5750(OC) 850mhz 2GB
RAM-[DDR3-4GB Matched RAM w/ Heat Spreaders]HYperX BLU
cpu-cooler- H60 closed loop water cooling.
Reply




Users browsing this thread: 1 Guest(s)