Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Smackdown SYM (New type of error)
#11
Then, is your problem solved for now ? Or maybe you can direct us to the link that contains the Russian guide.
SPECS:
i7-2630QM
NVIDIA GT540M
500GB SATA
4GB DDR3
Windows 7 Home Premium 64-bit
Windows 7 Professional 64-bit
Windows 8 Pro 64-bit


Acer Aspire 4750G
Reply

Sponsored links

#12
No, actually I don't think anything has changed. I mean don't get me wrong, I appreciate any input on how to run the emu more correctly, I'm grateful for any such advice. But as for this specific issue, I didn't mean to imply that it's any better because it's not, unfortunately.

I did go back and edit my last post to contain the thread that translated Russian's instructions though. And that thread itself has a link to the original Russian thread, so all the info that I'm using is in those links. I did notice upon re-reading that there was some discussion about an elf file being modified, and questionable legal ground, etc. But I have no idea what they're even talking about so I figured I'd leave that one alone.
Reply
#13
Have you guys been able to make anything out of those instructions? Am I doing something wrong? Still can't get the CRC to show a different number than the patch.
Reply
#14
Let me clarify how patches work for you:
Each PS2 game has an ELF file in it (think of it like the exe of the game). PCSX2 takes that file and calculates a unique number for that ELF file, called the CRC.
Then, if enable patches is checked, when you run a game PCSX2 will search the /patches folder for a patch file named after the CRC of the game you are running. If it finds one, it loads it else it does nothing.
So easy way to check if the patch is working for you: Enable Console in PCSX2, run your game and note the CRC number the Console displays on the title bar.
Then go in your /patches folder and check to find a patch file named CRC.pnach (where CRC is the CRC number of your game).
If you find it, it means that if you enable patches in PCSX2 this patch will be properly loaded and activated.

You never mentioned if you tried remaking the image with imgburn or if you tried using beta 1888. Also make sure you use SPU2-X as sound plugin
[Image: newsig.jpg]
Reply
#15
I'm sorry, I did forget. I installed and ripped my copy of the game with Imgburn, and I get the same result. I have had the console enabled the entire time, that's how I was able to see (in green letters) what the CRC result of the game is. No matter what, it keeps showing up with the exact same letters and digits that make up the name of the Smackdown SYM patch that's in the PCSX2 patch folder. According to those instructions, I found the patch, which was named something like B0AE1898, and from what I could understand, when I start the game the CRC should be different than that. But it's not, it's the same B0AE1898. Something must still be wrong since the other people in the thread reported that their CRC numbers are different.
Reply
#16
??? If you read what I said, you want it to be the same for the patch to work. If your game's CRC is different than the patch filename, it won't load it. Anyway a simple way to see if the patch is loading is checking the console. If it displays patch found and says game title etc it means it loaded
[Image: newsig.jpg]
Reply
#17
No I did read what you said. But there's a conflict.

Here's what I make of this, according to those instructions:

1: The patch for Smackdown SYM is listed as B0AE1898 already in the pcxs2 patches. I didn't copy it to that or anything, the patch already came, with that name, in the patches folder, when I downloaded pcxs2. The instructions said that that specific patch, B0AE1898, is the one for Smackdown. Ok so far, so good. There's a patch in the folder that came with the emulator, and that thread told me that B0AE1898 is the one for this game.

2: Here's where the confusion comes in: According to those instructions, B0AE1898 is NOT the correct name for this patch, because supposedly when one starts their game of Smackdown SYM and looks at the console, the CRC numbers will not be B0AE1898 but rather a different set of characters. I am then supposed to take those characters and rename the patch to match them. Thus, like you said, the patch and CRC will match. See, the problem is that right now, my game's CRC and the patch DO match, the characters are identical, and that's (supposedly) why the game does not work. According to the insructions, the game should be giving me different numbers and the patch should be renamed to reflect these different numbers, at which point the game should work. But I don't get that, I get the same B0AE1898 that, I guess, is making his not work.

I mean, I believe what you're saying, totally, and I'm sure you're more correct than the people in that thread. But I'm just really confused- they say that their CRC showed them different numbers than the default numbers that came in the patch's name, and all they had to do was rename their patch to match those new numbers, and the game would work. But I'm not getting new numbers like they did, my game shows the same numbers that the patch shows. And clearly they're doing something I'm not able to, and I just don't understand what is being done differently.

Again, there was another user in that thread who said that he helped in some way by doing something with the elf file. But since I don't know what he's talking about, and since the legality of that was challenged, I don't want to ask anything I'm not supposed to.

I guess I'm just trying to say that according to their instructions, the patches should match at the end. But they're not supposed to at first- they said that when they ran the game, their CRC characters were not the same name as the patch, and they just renamed the patch to be the same as what the console CRC characters were. If I'm not getting any different numbers, I have no idea how THEY did. You know what I'm saying? Ugh. It's so confusing. I'm sorry to have opened up such a troubling issue.



EDIT: What????? On a frustrated whim, I just tried to run the game again, changing nothing but enabling the patches again (after earlier turning them off as you suggested). NOW, the game works. This is a good thing, but it's driving me nuts...I have NO idea, NO clue whatsoever, why it suddenly works now. Not only does this completely invalidate EVERYTHING that was said in that thread I linked you to, but it confuses me because earlier I DID have patches enabled, and the game wouldn't work. Turned them off, still wouldn't work. Now I turn them on again, and it works??? In addition, this is the original ISO that I ripped with DVD Decrypter the other night. So in other words nothing was changed since the last time I tried to play, other than turning patches off, and then on again. Huh!?

Forgive me, I've gone on so long about this, and I really don't mean to go on at such length or sound like I'm trying to cause problems. I just want so much to understand what the heck is going on, lol.
Reply
#18
If it works, stop worrying Tongue
[Image: newsig.jpg]
Reply
#19
(04-30-2010, 03:35 PM)Bositman Wrote: If it works, stop worrying Tongue

Yeah, no, that's sound advice, lol.

I'd just like to know what I'm doing, I like to learn so I get a better grasp of the program and don't have to bug you guys again. Especially after ALL that.
Reply
#20
Now I wake up today, and it's back to not working again. I changed nothing.

This is very, VERY frustrating...
Reply




Users browsing this thread: 1 Guest(s)