So I tried downgrading from the latest SVN to 1.0.0
And I had a lot of issues. First of all, I didn't realize the official stable release was an installer and that bugged me, because the SVNs are all just the files without any installer. The v1.0.0 that I tried to use did not recognize my memory card files at all or even save states. My bios would not even register in the browser that detects bios files. So I gave up and used the latest SVN again to my disapproval. Because resident evil 4 STILL does not save without corrupting data.

Sponsored links


First release is a regular installer

Second is a web installer (will install anything missing like latest DX)

Third is binary (just like SVN drops)

Memory card format has not been touched in ages and is more or less a raw PS2 memory card dump. Memory cards are fully supported between all versions, if there is an error there it's most likely in where you put your memory cards at or that you installed PCSX2 to the program files directory (solution there is to either move it out, or run as administrator)

Save states, however, are version DEPENDANT and will not work between SVN and 1.0.0 (or any other major version).
[Image: 2748844.png]
Ah I see, the save state thing I can understand. But... the memory card thing. The SVN description said that there were going to be issues.
(07-22-2013, 05:52 AM)joshsonic26 Wrote: But... the memory card thing. The SVN description said that there were going to be issues.

It didn't say that there are GOING to be issues, but rather that features were added to memcards, so it's possible that something got broken accidentally. After some testing by the devs it seemed OK, but later an issue was discovered with memcards and persona3 (it's being worked on), and it's yet unknown if other games are affected as well. This is on r5703 (and later for now).

The point of SVN builds is for testing, and while the devs try to not break anything, occasionally SVN builds might have issues. If you can't live with that, use the release or beta builds.

If you want to help testing, compare your experience of r5703 with earlier builds, and if you notice a different behavior, please report it here. Thanks.

Users browsing this thread: 1 Guest(s)