Socom Still Graphical Errors
Below is my original post.  I thought ticking a game fix helped, but it didn't.  Apparently the ONLY WAY I can get Socom to run without any graphical glitches is to move the EE cyclerate slider in the hacks section to -1.  I use the MTVU 3+ core speedup and it plays like a normal PS2, but there is another problem with this.  It has those huge fps drops you would experience on a real PS2.  I don't get why I'm stuck with butter smooth gameplay but it isn't worth it with horrendous graphical errors.  Or, I can play without any graphical errors and experience the terrible fps drops I wanted to leave behind on the old PS2 days.  Can anyone explain what is going on here?

System specs:

CPU : FX-6300 OC'ed @ 4.4ghz stable

GPU : Sapphire Tri-X r9 290 1000,1300 no OC

My problem is this.  I get the rainbow texture glitch and garbled HUD words/text fairly often throughout a level.  I'm using custom internal resolution at 1280x720.  I've tried 4:3 and 16:9.  I noticed this emulator doesn't like OpenGL with AMD cards... So, I've tried D3D11 hardware and software both.  I have also tried both those plugin settings with speedhacks set to PRESET 1 safest with everything off and MTVU turned on as well.  It's fairly disappointing considering the game play is very smooth, but I can't seem to get past these random texture problems.  Also is there a way to make objects appear faster?  It seems like I have to run up close to certain objects in a level sometimes for them to appear and then they disappear when I go into the distance. [Image: glare.gif]

Link to images:

It does this the most often, sometimes the crosshair, player models, and background/sky textures flicker as well until I start moving again.

Sponsored links

Please keep it to the original thread, there was no need to make a new one

Original link:
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!

Users browsing this thread: 1 Guest(s)