Some hotkeys not working in 0.9.6
Well, considering I couldn't find a topic about this it's probably not a bug but something I did wrong.

I downloaded the 0.9.6 installer, installed the emulator, copied over a few folders from the old directory where I installed 0.9.4 (like bios, memcards, plugins), and tried some games out. It's all working great compatibility-wise, but when I press Escape, F1, F2 or F3, nothing happens. Swapping interlacing with F5 works, though.

My comp's a Vista 64bit machine. Savestates and escape worked perfectly in 0.9.4 and a few unofficial revisions I tried out.

Sponsored links

sometimes a game causes PCSX2 to stall (the bios does too annoyingly) so you may want to try hitting it more than once
Do you have savestates from 0.9.4 inside sstates directory...maybe that's the problem(0.9.6 don't support loading savestates from 0.9.4 and maybe when you try to save something goes wrong too).Also make use that you don't use the old ini's from 0.9.4 configuration.

You may try just to be sure to install pcsx2 in new directory and see if the problem is still there.
Sorry, I wasn't clear. My old version was installed in Program Files (x86)\Pcsx_0.9.4 while I installed the new version in Program Files (x86)\Pcsx2.

I made sure not to use my old .ini file, so that can't be the problem. I also tried holding the Escape/F1 buttons and tapping repeatedly, neither worked.
Are you using different pad plugins for pad 1 and pad 2? Think there's a LilyPad bug (With 0.9.9 and/or earlier, not the latest SVN one) that would cause issues with keypresses if you set LilyPad to pad 1 and Xpad to pad 2.
I'm using Xpad 0.1.0 for both controllers.
Could be an Xpad issue. Try another pad plugin. It's the pad plugin that passes the keypresses to PCSX2.
Thanks, swapping to Lilypad solved the issue.

Users browsing this thread: 1 Guest(s)