Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Soul Calibur 3 language glitch ?

So, whenever I start SC3 using the (full) option, so it starts with the Spanish language, there are some text glitches like this (·$/&$!·press [email protected]%&/) and one game glitch, example if I start a fight,the characters are moved from they position almost to the end of the platform facing other direction. If I run the game (fast) the game start in English and everything works perfectly, why ? I tried different bios versions, all of them show the same glitch.

I don't have any problem playing in English, but I'm not the only one playing ^^ other players want to understand.

Thanks any help!

Sponsored links

Does the bug occur on the PS2?
PCSX2 has some strange issues with SC3, I also get nasty bugs if I don't select 60 Hz in the initial selector after booting the game.
[Image: newsig.jpg]
No that I recall, I don't play with my friend ps2 since 2006 lol.

And I always choose 60hz. Do you also see the face bug in the character screen, you see the face then it disappears ?
Hm that shouldn't happen anymore. Which PCSX2 version are you using?
[Image: newsig.jpg]
#6 (svn)
I just tried it with full boot and it was fine for me...SCES 53312, CRC BC5480A3. No strange text and no SPS faces in character selection
[Image: newsig.jpg]
Thanks, this is my crc 5E24C248, it means my game is corrupt ? o_O did you tried the game in spanish ?
NO that means that your game is not listed in the CRC list ( which suppose to auto detect the game and auto apply fix ) Smile
I don't get a language select so you probably have another version of the game
[Image: newsig.jpg]

Users browsing this thread: 1 Guest(s)