Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Speedhacks stopped working.
#1
So, I have been using pcsx2 for quite a while now.
Currently using r5265.

This morning I was playing Kingdom hearts 2 Final mix.
GSdx5268:
DX11 hardware
x3Native
Shadeboost on
Texture Filtering on.

Speedhacks:
EE cyderate 1
VU cycle stealing off
The 3 recommended options and MTVU.

I could run the game at 60fps constantly, no stuttering, but my english translation patch was bad so it caused crashes.
So I patched my clean ISO with a better patch that doesn't crash.
Yet now, both the old ISO and the new ISO barely get to 31fps with the same settings. Sad

I tried lot's of things, as sad as it is even x2Native barely gets to 53fps. Even restored emulation settings to defaults/first preset.
I believe the speedhacks stopped working, I disabled and re-enabled them, yet there's no change in FPS. normally that would have got me from 47 to 60, yet it was 31 to 31, no differense.

I also tried changing render mode on GSdx, same thing.
I have no idea what's going on, I also tried to use some old revisions of pcsx2, same stuff, speed hacks don't make a differense anymore.

Any ideas? Some extra info: I think the game got slightly darker since the morning.. I tried disabling shade boost but it still doesn't fix the problem.

CPU: i3 at 2.56
GPU: 420m. (yes it's a laptop, but as I said, it ran fine this morning, so I don't know why it doesn't anymore.)
Reply

Sponsored links

#2
i think it's not true
you maybe have other program running and disturbing your pcsx2's emulation
e.g. antivirus software such as AVG,ESET or other scheduled task auto-defrag,auto-file indexing,MS office's FindFast

also show us your list and number of process in the task manager.
MAIN RIG:i5-7600(3.5ghz)GTX 1050Ti 4GB/128bit/gddr5,Win 10 Pro(x64),ASUS ROG B250G,16GB HyperXFury ddr4 RAM,Samsung M.2-SSD 500GB
SUB RIG:i5-4670(3.4Ghz),ATi Radeon HD7770(GDDR5+128-bit+1GB),Win 10 SL(x64),ASUS H8M-E,8GB DDR3 RAM
Reply
#3
Will do later, no time at the moment, but that's not the issue cause I monitor everything. Tongue

Everything was fine, so give me some other suggestions if you have any, I'm gonna check that later to be sure though and let you know.

EDIT: NVM, problem resolved itself after a system reboot. Weird that it didn't the first time.
If anything it actually runs better! 20% lower EE than it used to be.
Reply
#4
i am having trouble with these recent speed hack issues but some games such as ratchet have been running better now
Reply




Users browsing this thread: 1 Guest(s)