Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Sporadic framerates
#1
I'm running PCXS2 on a fairly old machine without a dedicated graphics card, so let me start by saying I know there might not be much I can do about this, but it seems worth asking since I don't know very much in terms of how to optimize my settings. The title says it all really--more than half the time games seem to run at around 60fps, but the rest of the time they nosedive to anywhere between 45-55 fps kind of unpredictably. I'm trying to play Silent Hill 2 right now and it seems to happen mostly during cutscenes (which seems weird to me because the graphics quality in cutscenes is about the same as in gameplay?). For comparison I booted up a Dragonball Z game (which lagged hardest at the character selection screen[?] and pretty significantly during fights) and Katamari Damacy (which showed absolutely no slowdown between cutscenes and gameplay).

My specs are as follows:

Windows 7
Intel Core i5-2430M CPU @ 2.4Ghz (quad-core)
6 GB RAM

Speedhacks are on
MTVU is on

Are there any other settings I can/should tweak?

Edit: forgot to mention I'm using PCXS2 ver. 1.4.0 on Windows 7.
Reply

Sponsored links

#2
start by setting windows power plan to performance mode
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
@jesalvein: Just tried that, framerate dips were about the same + happened in the same places across multiple games
Reply
#4
What are your GSdx settings? Also, download the latest dev build here and see if your framerate improves: https://buildbot.orphis.net/pcsx2/index....rev-v1.5.0
Reply
#5
@CK1: The devbuild didn't do anything for me, but in looking at my gsdx settings I realized I hadn't tried toggling "Allow 8-bit textures" on which helped a TON. It's much better than before but still has its laggy moments, so if you or anyone else still has any recommendations I'd gladly take 'em.

[Image: jgTXOR]

Don't know why the screencap of my settings didn't show in the post. [link]
Reply
#6
You can switch to the OpenGL renderer for a speed boost but otherwise that's as fast as it's going to get.
Reply
#7
@CK1: it keeps telling me that something's incompatible when I switch to OpenGL (hardware or software)--is there something I need to download before it can work?
Reply
#8
I assume you're running off of Intel Integrated Graphics? See if there's an update for the drivers on the Intel website.
Reply
#9
My drivers are all up-to-date (again, this comp is like 7 years old; Intel's probably done upgrading drivers for my processor) so looks like no OpenGL for me. ): Oh well. Thank you very much for your help!
Reply
#10
DBZ games are laggy beast, unless something has changed. With your laptop you won't get much more then what you are getting. Even though you are riding 1400 STP the integrated graphics does suck some juice from the CPU due to the heat it causes.
MOBO - ASUS Maximus VII Hero
CPU - Intel i7 4790k 4.6GHZ
RAM - 16 Gigs DDR3 2133mhz
HDD - 3 500 Gig SSD 1 3 TB 7200 RPM
GPU - EVGA Nvidia GTX 1070 SC
OS- Windows 10.
Reply




Users browsing this thread: 1 Guest(s)