Star Ocean 3 Crashing at Gemity Battle Arena (Turbo Controller)
Hi everyone, I am experiencing a very specific instability with Star Ocean Till the End of Time NTSC (59.94 fps) -U version. Both discs were created with Alcohol 120% from a used copy that was purchased at Gamestop. While they were used, it is still in great condition in both the Playstation 2 as well as on desktop emulation.

However, I am experiencing a very specific crash that appears to only repeatedly appear at the Gemity Battle Arena. I want to build my battle counter up to 99,999 (only for completion purposes, but due to my OCD in perfecting completions of role-playing games, this task is of utmost importance to me), while at the same time I would like to make this task as easiest as possible. I've enabled pcsx2's built-in turbo controller, by checking both the "turbo" and "flip" checkboxes in the lilypad plugin, which the combined result is that PCSX2 will continually press the button designated with both of those checkboxes. I've only tested PCSX2 build 1.0.0 and 0.9.6, and seems to only work in 0.9.6. However, I keep crashing every single time at arbitrary time intervals. Here are my following specs:

i7-3770K overclocked to 4.8 Ghz
Samsung low-profile Ram @ 1866 mhz 8 9 9 24 1T 8 GB
Sapphire Radeon HD 7950 Core: 925 mhz Memory: 1250 mhz
Samsung 840 PRO SSD 256 GB
Windows 7 Ultimate 64 bit

Tried on PCSX2 1.0.0 r5350 as well as the Official PCSX2 0.9.6

I tried everything that I can think of: Disabling all speedhacks (and I mean all speedhacks), Enabling various combinations of speedhacks, Using only memory card saves and not save states, Using only save states, Disabling Patches, Enabling console mode to see if there are debug hints (however, the console doesn't display anything before crashing) Running the 3770K at 4.6 Ghz and also at stock clock of 3.5 Ghz and stock voltage, resetting the Bios CMOS, Software mode (this pretty much rules out the graphics card), Gsdx 9 as well as 10/11, PCSX2 1.0.0 (since "flip" and "turbo" enabled in the lilypad plugin doesn't constantly spam a designated button in 1.0.0 I just enabled the "turbo" checkbox, and put a 1,400 page textbook on my designated button for Cross to constantly generate battles at the Gemity Battle Arena).

Here is the kicker: I was once able to perform this with 100% stability in the past. This was how I was able to get to 52,000 battles to collect that battle trophy. I guess I just cannot seem to find that magic combination that allowed me to perform this in the past. Also the game runs extremely stable. I went from New Game to beating Freya with no crashes except for once or twice where I was loading a "tainted" save state, and I was aware that this could happen. However even without save states, turboing at the Gemity Battle Arena crashes with 100% certainty. Ideally I would like to leave it overnight while I sleep, and wake up to save it before it crashes. I think the longest I was able to run this was for 4- 6 real time hours (about 20 to 24 game time hours) before I needed the computer for something else. But I would rather not have to monitor the game.

I am reaching out to people with veteran pcsx2 experience. I know there is something that I'm not currently doing right, because I was able to do this before... If you have tried turbo controller in pcsx2 that is a plus. Please point me in the right direction. I've done some research but I have not found anyone in the same boat as me, except for this guy:

I wonder where I can find this "Gsdx 0.1.15 Revision 1469", sounds like it would be compatible with a very old PCSX2 build.

Another lead is this guy:

He is running bunny races, but that is essentially the same thing I am doing, running turbo mode in Gemity to rack up what would otherwise be extremely grindy tasks.

When running at 4.8 Ghz I get roughly 160 minimum fps (all speedhacks disabled) with D10/11 Hardware mode, and at 4.6 Ghz I am getting 150 minimum fps. Running at 4.8 Ghz is preferable as PCSX2 is about 267% of actual game speed, and I could complete my 99,999 battles over a few nights.

Attached is a picture of the exception error. While the picture shows me with League of Legends open, I have indeed tried turboing at Gemity League of Legends not running, so we can eliminate that as a factor.

Forgot to mention that I have the Tri-Ace VU Add/Sub Hack enabled (otherwise I wouldn't have been able to get so far into the game much less in-game). I also tried various combinations of CPU calculation modes such as Extra + Preserve Sign, Full, Unchecking Flush to Zero and Denormals are Zero as well as checking one of each and checking both. None of which helped, in fact if I put Round Mode to Nearest, the game wouldn't even boot.

Another sidenote: Why is my CPU-usage so low, is my GPU bottlenecking my CPU? I feel like I should be getting higher framerates, but that's OK, my main issue is stable auto-battles at Gemity.

Sponsored links

If what you're trying to up is a simple battle counter, you could cheat and max it out.
Lol exactly, why still use those methods in XXI century?Tongue I mean using turbo/locked buttons to "grind"?

If you really need to obtain everything and don't want to do it normally... use cheat codes or download 100% save ~_~, it has exactly same morality as bug-using, bot-using or turbo/locked buttons, but opposite to those methods doesn't waste electricity.
It really doesn't run up the electricity tab that much. Not with all of the other appliances, and I just need to run it for a couple of nights once I re-find the correct settings.

Here is why I prefer to turbo: I have tried the code and .pnach for Maxing bunny points at 9,999. While it did indeed get me to 9,999 Points, the Bunny Race is forever broken beyond that (while I could still place a bet, the actual race refuses to start and the conversation will loop). So there is definitely a game-breaking difference between artificially overwriting the bunny point counter and incrementally increasing the counter through experiencing the actual events/Bunny races. While I have no proof, I feel the battle counter has a similar thing going on. A edited number through hacking glitching up the game.

There is no save with 99,999 battles. Tried this already.

While I agree with you both, my OCD drives me to keep trying to turbo, because I've done it before, two other people have done it, and it's rather effortless anyway once everything is setup.

Thanks for your input, but would prefer to focus the rest of the attention towards successfully "turbo'ing" and perhaps some insight on how PCSX2 utilizes the CPU rather than whether I should turbo or download saves/use .pnaches.

I'm starting to think perhaps Star Ocean: TEOT does not like buttons smashed in rapid succession as PCSX2 succumbs to exception errors. I've tried Auto-keyboard software that would spam the button specified for turbo in PCSX2 at various time intervals all to no avail.
Uhm miseru you mean XXth century Tongue we're in the XXIst atm Laugh
@Strife I wrote it correctly as far as I know.;p I asked why use it IN XXI century not why use an XX century method;p.

@Experiment maybe post the code you used? Save game would be nice too. SO3 is generally very sensitive to codes and many of them are game breaking, codes not being 100% compatible with pcsx2 doesn't help;p, but it doesn't mean the same thing cannot be cheated in different ways;p. Might give it a try later if I get the save for that, since I dunno if I can find mine;p.
If it's turbo that causes the instability maybe different PAD plugin would help. If you use an Xinput compatible controller I would recommend Pokopom which is pretty much plug and play.
Anyway cheating is always best imo<3.
Have to say, miseru99 is right about the XXI century thing.

This is the 9,999 Bunny Points Code that I was talking about:


Note that Star Ocean 3 uses the following .pnach:


I can confirm that using a memory editor like T-Search 1.6b to edit bunny points to 9,999 does not have issues. However Star Ocean 3 has floating memory values except for the memory address for Bunny Points, and nothing else appears to be editable. Believe me I've tried.

Thanks, I'll look into Pokopom controller plugin. Using a different controller plugin is a variable I haven't tried yet. Also if you would like I can include my memory card save for Star Ocean 3 that has the number of battles I have so far after I get back home from work late tonight. Gotta run and get ready for work right now.
That code writes/replaces some assembly code, and I'm pretty sure the one starting from E(multi line skip conditional code) was broken or at least not fully implemented in PCSX2. Same thing can be written by using single line skip conditional codes which should work in pcsx2^_^, soo maybe just maybe that's a simple solution.

Our(hopefully) working code build by two single line skips instead of one multi line one should be:
//9,999 Bunny Points code hopefully fixed for pcsx2

I might made some mistake ;c as I couldn't find any save close to there and wrote that without any testing, if this code still breaks something upload that save and I'll see where I failed or if the code has other problems.^_^

Generally pcsx2 by itself has just few basic code types implemented, so all more complicated ones like pointers, or those multi line conditionals like in here simply fail;c. Codebreaker itself seems to work under pcsx2, soo it could be an alternative workaround when codes are too bothersome to write differently;p.
I still need to find a way to turbo up 99,999 battles as that is my top priority. I'll try the bunny point code when I get home tonight. Also, the memory card is 64 MB, is that file too big to upload or will it be OK?
Compress it before uploading, it should be much smaller.

I found one of my backup savestates was near the place so I tried messing with the code and have to straighten some stuff. Turned out the E code does work just as well as the D one, they both fail when first digit of second number is above 0, soo while it brakes many codes, this is unaffected;3.
On the other hand I checked how the cheat actually works, it's basically jump to empty memory, do original code there add loads of points to it, and jump back there's one more command after jump back which I don't understand as mips assembly isn't really something I ever learnt, but it basically works same way as we would inject our script to pc game. Cheat Engine debugger is somewhat useless here, so I'm totally clueless why exactly the races doesn't work after injecting it;p, might be some anti cheating protection.

I did menaged to find the value for points in totally different adress through, it might not be static as I didn't checked it much other than around the place, but at least it doesn't break anything ~_~
//set bunny points to max after visiting the prize exchange
patch=1,EE,2054E400,extended,0000270F //9999
I basically used the broken code from earlier to set different values to find this easily in case it will not work for you, if you upload your save I might just edit that one for you, managed to get all prizes and still "enjoy"(lol;p) bunny race. Gonna play for a bit more to see if I can find battle counter.

Users browsing this thread: 1 Guest(s)