Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Star Ocean: Till the end of time - Weird frame rate issues/stuttering.
#1
PC specs:

Ryzen 5 2600x
GTX 1080
1TB Samsung Evo 970 NVMe 
16GBs DDR4 3200mhz
Windows 10 64 bit

I've tried the latest developer build on Orphis, and the latest stable (1.6.0), and even tried some earlier versions, and all of them have this issue.  

Right after getting into a battle (most of the time), the frame rates dip to like 55-58, huge stutter occurs, and then they rebound back up to 64-68, even though I got the default frame limiter set (not using turbo).  

This seems like some sorta weird frame limiting issue specific to this game.  

If there's a box I need to check or uncheck to fix this issue, or one of the misc game fixes can solve this, I'll try that.

I also had this same issue years ago when I played this game on an entirely different PC, and I was hoping this was fixed, and maybe it is using some specific setting/configuration I don't know about.

I'm gonna boot my old PC up and test it, to see if it's something specific on this rig, and will report back in a bit. I also got a gaming laptop that's a couple years old with an 8th gen I7 I can test.

*Edit* - this occurs on 3 different rigs for me. All of them should otherwise be able to technically handle this game on PCSX2. Is this a known issue? The game otherwise runs fine, but hearing busted audio and a jerk in the frame rate in 3 out of every 5 battles I get into is super annoying though. Really hoping there is a fix for this, otherwise I might have to wait until there is one.
Reply

Sponsored links

#2
Changing these settings in GSx in 1.6.0 seems to improve this issue a little bit, but it's not a 100% fix, it still does it, just left often, and the stutter isn't quite as bad:

Direct 3D11 HW
Mipmapping (fast)
CRC hack level (Full - Direct 3D)
Date Accuracy OFF

Speed hacks don't appear to have any effect on worsening or improving this issue, tried them on and off, and with each setting box checked, and all the boxes checked, doesn't matter.

Also no difference between native resolution and running it at 4k. A GTX 1080 runs this game 4k without any issues.

*Edit* - This game needs a specific frame pacing fix. It literally makes no sense. I'm seeing really odd spikes in frame rate too, like occasionally it'll randomly just jump up to 108-116% speed for literally no reason. Just randomly walking around doing misc stuff with default limiter. The only fix is to set the game speed to 150%, it'll dip when you start a fight, but it won't get low enough to stutter, which means this is 100% an emulation issue here.
Reply
#3
Frame pacing was improved in the dev builds, so it's possible that 1.6 is the issue here.
Reply
#4
It still happens for me on 3 different systems, even on the latest developer build. I don't see anything in the logs, the logs are clean, with no errors of any sort. If there was something wonky going on in the logs, I'd post it, but there's nothing there.

If anyone else is having the same issue as me on this game, the only fix appears to be to run the game at over 100% speed to keep the dips from stuttering the audio, because the game isn't stable at 100% speed. It's not just dips, but random spikes in frames as well. Sometimes it'll spike, then drop back to 100%. The spikes can range from jumping to as high as 116%, before dropping back to 100%. Even when I lock the turbo to let's say 150%, the spikes and dips still occur, sometimes it'll spike up an extra 16% usage, etc. Out of all the games I've played, none of the others I've played do this. So it might be specific to this game.

Unfortunately, I've done all the testing and toying around with misc settings that my patience allows. I've put this game on the back burner, and will maybe try again in another year and hope the issue is fixed in whatever the developer build is 1 year from now. Other games run fine, and the newer versions of the emulator seem to be more accurate with less visible glitches, so a bit progress has been made. I also don't see that weird ghosting effect anymore in 3D games when upscaling the resolution.

FYI, I dump all my disk ISOs using ImgBurn, and it tells me if there's bad sectors, so anything that ImgBurn completes without errors is a good dump based on my experience of dumping countless disks. So, there's 0% chance of this being a bad dump. It would give me errors in ImgBurn, and in PCSX2 if there was. The same dump also works without issue on my free MC boot modded PS2 with a HD loader. I still prefer to emulate it on PC though, because of the features that emulators bring, like increasing the resolution, or applying turbo speed, etc. Especially in these grindy RPG games.
Reply




Users browsing this thread: 1 Guest(s)