Star Wars Battlefront 2 trouble

I'll start by saying I know absolutely nothing about emulation settings and all that jazz so plain english would be appreciated.

SWBF2 runs perfectly until I get to the point where it asks me t choose a command post for the first time. It suddenly drops to ~5 fps and stays there.

I can run FFX and FFXII perfectly at 50 fps with very few slowdowns occurring.

I've already looked through a number of threads about this game and have done everything they have advised (4gb exe patch, fiddling with the GS plugin, etc.) and haven't had a single change in my predicament.

My computer specs:
i5-3210M @2.5 Ghz (can run at 3.1 turbo but I have on idea how to do that)
Intel HD Graphics 4000 (1760 MB Dynamic Video Memory)
500 GB HDD (I run my games from the built-in hard drive)

PCSX2 settings:
SSE41 GSDx9 (Hardware)
+ the rest are at default for PCSX2 0.9.8


Sponsored links

Start by using the fresh PCSX2 1.0, and also try checking 'native' in GSdx for that scene, sounds like some heavy GPU usage/memleak that kills your HD 4000
[Image: newsig.jpg]
I installed the 1.0.0 update and ran it in Native resolution and got 30-40 fps which is pretty decent.

Thanks for the help.
Nice glad it works better for you Smile You could also try enabling the new MTVU speed hack, see if that helps too
[Image: newsig.jpg]
I have the exact same issue here, but it hasn't been solved by setting it to native, although it is only version 0.9.8....

Is it possible to fix without downloading the latest version?

System Info:

Dell XPS L502X
Intel Core i7-2630QM CPU @2.00GHz
6.00 GB RAM
Try not to necro... should have made your own thread this thread is ancient
CPU: Core i7 3610QM 2.30GHz (Turbo up to 3.10GHz)
GPU: Nvidia GeForce GTX 670m 3gb
RAM: 16gb ddr3
[Image: images.jpg]

Users browsing this thread: 1 Guest(s)