Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Star Wars Battlefront 2004 PS2
#1
Hello, I'm having trouble with Star Wars Battlefront 2004. What are the recommended settings for this game as it runs very slow. I have tried switching plugins and settings but to no avail. I have frame limiting turned on by pressing F4 but it is still slow. are there any speed hacks written directly for this game that I need to download or is there something else I could try?
OS: Windows 7 Ultimate 64-bit Operating System
CPU: Intel Corei5-4430 @3.00 GHz 3.00 GHz
Motherboard: Asus H97-PLUS
RAM: 8.00 GB
Storage: Seagate ST3400620AS 400GB, WD MY Book Duo 0a10 USB Device 12TB, WD10EAVS-00d7b1 1TB SCSI Disk Device
Graphics card: NVIDIA GeForce GT 720, Memory: 1024MB DDR3
PCSX2 Version: v1.5.0-dev-2294-gafd6541ca


Reply

Sponsored links

#2
What GSdx settings are you using?
Reply
#3
Update I switched to the directx9 software plugin and turned the speed hacks all the way up in the GS settings. the game runs at normal speed but with some chop and with slowdowns when vangards and shock troopers use rocket launchers on screen. Anyone have ideas how to fix this?
OS: Windows 7 Ultimate 64-bit Operating System
CPU: Intel Corei5-4430 @3.00 GHz 3.00 GHz
Motherboard: Asus H97-PLUS
RAM: 8.00 GB
Storage: Seagate ST3400620AS 400GB, WD MY Book Duo 0a10 USB Device 12TB, WD10EAVS-00d7b1 1TB SCSI Disk Device
Graphics card: NVIDIA GeForce GT 720, Memory: 1024MB DDR3
PCSX2 Version: v1.5.0-dev-2294-gafd6541ca


Reply
#4
Why can't you use use OpenGL?
Reply
#5
(02-27-2018, 04:41 AM)smolderingchipmunk Wrote: Update I switched to the directx9 software plugin and turned the speed hacks all the way up in the GS settings.
Set those back to the default. Just set Rendering threads to 3 and enable the MTVU speedhack in Emulation Settings.
Reply
#6
(02-27-2018, 04:41 AM)CK1 Wrote: What GSdx settings are you using?

Still has some chop and slowdown when the vangard and shock trooper fire, but runs at normal speed otherwise.


Attached Files Thumbnail(s)
       
OS: Windows 7 Ultimate 64-bit Operating System
CPU: Intel Corei5-4430 @3.00 GHz 3.00 GHz
Motherboard: Asus H97-PLUS
RAM: 8.00 GB
Storage: Seagate ST3400620AS 400GB, WD MY Book Duo 0a10 USB Device 12TB, WD10EAVS-00d7b1 1TB SCSI Disk Device
Graphics card: NVIDIA GeForce GT 720, Memory: 1024MB DDR3
PCSX2 Version: v1.5.0-dev-2294-gafd6541ca


Reply
#7
Switch to the OpenGL renderer since you own a Nvidia card. You may get a small speed boost there.
Reply
#8
(02-27-2018, 01:00 PM)FlatOut Wrote: Set those back to the default. Just set Rendering threads to 3 and enable the MTVU speedhack in Emulation Settings.

Still this. Set the extreme EE and VU settings back to 0 or at least a lower setting.
Reply
#9
(02-27-2018, 01:00 PM)FlatOut Wrote: Set those back to the default. Just set Rendering threads to 3 and enable the MTVU speedhack in Emulation Settings.

running smoother but slower with those settings, I'm going to try to raise VU cycle stealing at 2.
OS: Windows 7 Ultimate 64-bit Operating System
CPU: Intel Corei5-4430 @3.00 GHz 3.00 GHz
Motherboard: Asus H97-PLUS
RAM: 8.00 GB
Storage: Seagate ST3400620AS 400GB, WD MY Book Duo 0a10 USB Device 12TB, WD10EAVS-00d7b1 1TB SCSI Disk Device
Graphics card: NVIDIA GeForce GT 720, Memory: 1024MB DDR3
PCSX2 Version: v1.5.0-dev-2294-gafd6541ca


Reply
#10
(02-27-2018, 08:22 PM)smolderingchipmunk Wrote: running smoother but slower with those settings, I'm going to try to raise VU cycle stealing at 2.

VU Cycle stealing won't help. Turn down your resolution a bit, that should give you the remaining FPS you need.
Reply




Users browsing this thread: 1 Guest(s)