Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
SteamLink/D3D issue (Burnout 3/Tekken5/etc)
#1
Hi there!

first of all: great work on the emulator. It brings back so many memories of my busted PS2 and I have so many titles left to explore.

But I have a question regarding SteamLink:

Some titles (mostly Burnout 3) run crap when using OpenGL while they run great while using Direct3D.

in game Burnout 3 dips to around 30fps.

Now all is well when I switch to Direct3D but it seems that when I start up PCSX2 through my SteamLink it defaults to OpenGL.

I couldn't find a flag to force it and was wondering if it was possible or if anyone had a solution for this issue? I would gladly completely switch to D3D as all games seem to run fine with it.

Any tips?

Also: any way to set 4:3/16:9 through flags (possibly in combination with the above)?

Thanx in advance!
Reply

Sponsored links

#2
In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
Reply
#3
Changing the renderer in Config -> Video (GS) -> Plugin Settings doesn't save it?
Reply
#4
(01-20-2018, 08:23 PM)FlatOut Wrote: Changing the renderer in Config -> Video (GS) -> Plugin Settings doesn't save it?

When I play directly on my computer it picks up the right config but through SteamLink it (seems) to default to OpenGL as the low FPS encountered when I am on PC with OpenGL seem consistent.

Any way to find out what renderer is used through SteamLink?
Reply
#5
(01-20-2018, 08:20 PM)CK1 Wrote: In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.
  • What games you are trying to play and if you are playing them from ISO or DVD.

Thank You.
• Intel i7 4770 @ 3.40ghz, NVIDIA GeForce GTX760, 8GB RAM, Windows 10.
• 1.50 Daily build
• Just changed renderer while local on PC to D3D, works fine. SteamLink doesn't seem to respect it.
• Burnout 3 ISO, Tekken 5 ISO
Reply
#6
The steamlink probably uses all default PCSX2 settigs, which means it will pick OpenGL because your GPU is by NVIDIA. It should be fast enough with your specs. On AMD GPU's OpenGL can be very slow because of driver bugs.
Reply
#7
(01-20-2018, 08:42 PM)FlatOut Wrote: The steamlink probably uses all default PCSX2 settigs, which means it will pick OpenGL because your GPU is by NVIDIA. It should be fast enough with your specs. On AMD GPU's OpenGL can be very slow because of driver bugs.

Afraid to say it doesn't cope well so do you perhaps know if there is a way to change the renderer? I'm thinking either --cfg or [i]--gs=?[/i]

I cannot seem to figure out where to actually specify it.
Reply
#8
(01-20-2018, 08:46 PM)ShootHere Wrote: Afraid to say it doesn't cope well so do you perhaps know if there is a way to change the renderer? I'm thinking either --cfg or [i]--gs=?[/i]

I cannot seem to figure out where to actually specify it.
You should be able to use --cfgpath="C:\PCSX2\inis" to target the inis folder where you keep your preferred settings.
Reply
#9
(01-20-2018, 09:05 PM)FlatOut Wrote: You should be able to use --cfgpath="C:\PCSX2\inis" to target the inis folder where you keep your preferred settings.

I had the same itching, will try and report back tomorrow. Although it does pick it up the screen ratio and upscaling (4x).

Thanx for your patience!
Reply
#10
Well as far as testing goes it seems to have fixed the Burnout 3 slowdown by pointing to the config folder in the Steam shortcut.

I am a tad surprised at this as it did pick up other settings such 4x resolution and widescreen.

Ah well for now it seems that was the answer, if I find out anything else I will report back!
Reply




Users browsing this thread: 1 Guest(s)