Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Strange Image Bars
#1
Hi, I recently downloaded the PCSX2 on windows, I thought it'd be great, since RPCS3 runs at 4k 60 fps with no issue at all, but this PS2 emulator has this weird issue, and I can't manage to fix it! Can someone please help? When I start a game, it has those weird looking lines across the screen. I've seen videos of people running these games on emulator, Soulcalibur II and Soulcalibur III in 4K too at widescreen ratio with no issue. I've seen people configuring as best the emulator but I can't take them off, although, to be fair, the games look amazing even with the bars on top of them. I linked 2 screenshots, and these are my specs:

Ryzen 3700X
AMD Radeon RX 5070
16 GB RAM

If anyone can help me to remove those annoying lines would be really appreciated, thanks!

P.s: also, how the heck do I change the language to spanish?


Attached Files Thumbnail(s)
       
Reply

Sponsored links

#2
set internal resolution to "native (PS2)" on latest buildbot 1.7.0
x2 or higher you will get the vertical black lines.

OR

use 1.5.0 builds--->under gsdx settings set custom reso to 1200x1200 or 1400x1400 or 1600x1600 only if you are under the influence of x2 or higher reso.
Main PC1:i5-4670,HD7770(Active!)
Main PC2:i5-11600K,GTX1660Ti(Active!)
PCSX2 Discord server IGN:smartstrike
PCSX2 version uses:Custom compiled build 1.7.0 64-bit(to be update regularly)
smartstk's YouTube Channel
Reply
#3
Those occasionally come up in some games. Usually when you do any scaling of any kind to the video and raise it above Native resolution.

Try using the Hardware Hack Merge Sprite option that is found in the new 1.6.0 version, and use the Round Sprite (Full), both at the same time. I would try Round Sprite (Half) on its own first, and if it works for your game, then go with the Half setting, and you can most likely leave Merge Sprite off. If it doesn't work with the Half setting on it's own, then use the Merge Sprite and Round Sprite (Full) together.

Usually people like to try adjusting the texture offset, but I find these tend to work better usually.


As for changing the emulators language, at the top just click Misc and choose Change Language.
Reply
#4
hey thanks for response! yeah, it was the sprite thing after all ^^ now it works really great! I'm having other issues with GOW now... but with most games works perfectly!
Reply
#5
(10-06-2020, 01:18 AM)StyloTiger Wrote: hey thanks for response! yeah, it was the sprite thing after all ^^ now it works really great! I'm having other issues with GOW now... but with most games works perfectly!

Your having issues with GOW? as in God Of War game? If thats what you are referring to, what issue are you having with it?
Reply
#6
(10-06-2020, 02:05 AM)DarkDream787 Wrote: Your having issues with GOW? as in God Of War game? If thats what you are referring to, what issue are you having with it?

Custscenes have a strange bar underneath and it lags in certain points, but mostly when I open chests. I recorded a video and took some pics, here: 

Cutscene: [color=var(--ytcp-link-color)]https://youtu.be/R8chQURH_hw[/color]
Gameplay Lag: [color=var(--ytcp-link-color)]https://youtu.be/5k9meLBxRqM[/color]


Attached Files Thumbnail(s)
       
Reply
#7
Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Please make sure to enclose your emulog in code tags like so (remove the empty space on the closing code tag!):
[code]
Pasted emulog goes here
[ /code]
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#8
(10-06-2020, 03:32 AM)StyloTiger Wrote: Custscenes have a strange bar underneath and it lags in certain points, but mostly when I open chests. I recorded a video and took some pics, here: 

Cutscene: [color=var(--ytcp-link-color)]https://youtu.be/R8chQURH_hw[/color]
Gameplay Lag: [color=var(--ytcp-link-color)]https://youtu.be/5k9meLBxRqM[/color]

Thats actually an easy fix. I spent a while trying to figure that out myself when I was setting up the game a while back. Just copy my settings I made for the game.

[ Video Settings ]
Renderer: OpenGL (Hardware)
5x Native Scaling (3x-4x Native Scaling if you get lag)
16x Anisotropic Filtering

[ Hardware Hacks ]
Round Sprite = Half (Fixes vertical lines and most of the green around things when upscaling) (Use Round Sprite = Full with Merge Sprite if you want less rainbow pixel artifacts around FMV's)
Sparse Texture = Force Enabled (Fixes random discolorations and garbled pixels down the right side of the screen)


Then there is this as well

Misaligned rectangle at bottom of FMV.
Status: Active
Type: Minor
Description: During FMV scenes, a black rectangle obscures part of the bottom of the image, usually in one of the corners
Workaround: In the in-game main menu, select Options and ensure "Progressive Scan" is set to "Off". Note that only the NTSC version of the game has this menu option - there is no known fix for the PAL version.

I noticed your screenshot says 50fps which is usually PAL framerate. If your using a PAL version of the game, as of now, you cannot fix those black rectangles in FMV, except maybe in software mode.
Reply
#9
(10-06-2020, 12:11 PM)DarkDream787 Wrote: Thats actually an easy fix. I spent a while trying to figure that out myself when I was setting up the game a while back. Just copy my settings I made for the game.

[ Video Settings ]
Renderer: OpenGL (Hardware)
5x Native Scaling (3x-4x Native Scaling if you get lag)
16x Anisotropic Filtering

[ Hardware Hacks ]
Round Sprite = Half (Fixes vertical lines and most of the green around things when upscaling) (Use Round Sprite = Full with Merge Sprite if you want less rainbow pixel artifacts around FMV's)
Sparse Texture = Force Enabled (Fixes random discolorations and garbled pixels down the right side of the screen)


Then there is this as well

Misaligned rectangle at bottom of FMV.
Status: Active
Type: Minor
Description: During FMV scenes, a black rectangle obscures part of the bottom of the image, usually in one of the corners
Workaround: In the in-game main menu, select Options and ensure "Progressive Scan" is set to "Off". Note that only the NTSC version of the game has this menu option - there is no known fix for the PAL version.

I noticed your screenshot says 50fps which is usually PAL framerate. If your using a PAL version of the game, as of now, you cannot fix those black rectangles in FMV, except maybe in software mode.

It moves basically the same, no difference :/
Reply
#10
Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Please make sure to enclose your emulog in code tags like so (remove the empty space on the closing code tag!):
[code]
Pasted emulog goes here
[ /code]
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply




Users browsing this thread: 1 Guest(s)