Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Strange Vsync Behavior with Front Mission 4
#1
I've only seemed to run into this issue with FM4, I haven't tested many other games yet.

But basically using PCSX2's vysnc or using RTSS Scanline Sync when in a specific scene the game is running with the framelimiter disabled at 90-110FPS (With MTVU Multithread disabled as it causes a 20FPS drop in this game) enabling vsync/framelimiter causes the framerate to drop to less than 60FPS.

Obviously with double buffer vsync if you drop below 60FPS you drop to 30FPS next and so on in multiples. 

It's only in one specific area so far when zooming the camera out to the max. In most scenes it works just fine.
At first I just thought it was RTSS Scanline Sync that was the issue as it can be finicky and CPU intensive it seems sometimes. (Using ScanlineSync x2 actually runs at full speed fine but not's intended to work this way so the speed cycles up an down.)
But enabling the framelimiter in the emulator and turning on the built in Vsync in OGL has the same thing happen in the same spot.

It's very odd that the game otherwise runs at almost 200% with all limiters and vsync disabled but turning on Vsync no matter how you do it causes it to drop below full speed.

Ways to get around this is to increase the EE cyclerate skipping to 2 which will just act like frame skip in this specific scenario(And seems to run fine normally) but maintain full speed.  Or using a specified sync timeout in milliseconds in RTSS will just allow tearing when this happens.


Any thoughts?


Current specs
Latest Git build in OGL HW mode (Same thing happens in SW mode)
Ryzen 5 2600x (clock speed varies from 4150-4200 when pcsx2 is running)
16GB 3200Mhz RAM
RTX 2080
ISO ripped and running off of SSD
Windows 7 (Running this off my W7 dual boot to avoid latency from DWM in Windows 10. Played through Maximo with ScanlineSync with no issues)

I have a save state of the exact spot it happens if anyone wants it.

EDIT: It turns out having HPET enabled was the major cause of the problem. It's not completely gone but severely reduced with HPET disabled.
At least with RTSS. With PCSX2 Vsync it still slows down significantly with Vsync on even though performance is at or above 60FPS.
Reply

Sponsored links





Users browsing this thread: 1 Guest(s)