Strange issue with ps2 controller mapping
So after much trial and error I finally was able to get the emulator setup. I have purchased a ps2 to usb converter for my original ps2 controller so that is what I am trying to use in game. When I try to map the buttons the
d-pad as well as the trigger buttons as well as the action buttons (square, cross etc) will not allow me to assign to assign them to the proper place. What is odd is that the analog sticks and well as start and select buttons can all be assigned to the proper slot. Please let me know if that question make sense. I posted my specs below.

Host Machine Init:
Operating System = Microsoft Windows 7 Home Premium Edition Service Pack 1 (build 7601), 64-bit
Physical RAM = 8147 MB
CPU name = Intel® Core™ i5-2500K CPU @ 3.30GHz
Vendor/Model = GenuineIntel (stepping 07)
CPU speed = 3.308 ghz (4 logical threads)

Sponsored links

Did you install the drivers for your adapter?
[Image: gmYzFII.png]
[Image: dvedn3-5.png]
Yes installed them do I need to put them in a special folder?
probably with your adapter their was some configuration utility.

Normally you can test if your connection between pc and ps2 controller is correct by checking those utilities.
There wasn't a utility just a CD with the drivers on there. I installed all the drivers that came with the CD. After reinstalling I loaded up pcsx again and still no dice.
In windows there is some kind of a gamepad-utility in the system configuration. I don't have an english version therefore I can not tell you how it is called.

Check if your controller is listed in the list of gamepads.
It is its listed as twin usb joystick. in windows. Also in the controller plugin settings in lillypad under device diagnostics it also has twin usb joystick listed twice.
If you use the windows utility and click on settings you can normally see all buttons that were supported by you pad. If you push them you can check if every button is working...

You can also look into the attachment how it is looking in my german windows...

Attached Files Thumbnail(s)

That is what mine currently looks like. I am able to get it to viberate when I test it. The analogue sticks work. The buttons i describe above light up when i press them but still no change when I press the command buttons.
I would not expect to see buttons work with lilypad if they don't work there.

Why have you two controller in the list? What happens with the other entry?

Users browsing this thread: 1 Guest(s)