Strange problem with XInput Wrapper (solved)
Hello, I am desperate for some assistance - I have been messing with this program for the last 4 hours and almost everything is working, except something important!

I am using a DS3 - I installed the program as per the instructions. It is connected and shows up fine in SCPMonitor.exe whether it is connected through Bluetooth or USB, great!

When I run SCPUser.exe, all buttons and inputs are registering perfectly.

In Device Manager under USB Devices I am seeing BTH DS3 Device, USB DS3 Device, and XBOX 360 Controller. BTH DS3 Device and XBOX 360 Controller are ALWAYS listed. USB DS3 Device comes and goes as it is connected/disconnected.

When I run SCPServer.exe, it says Host Address : Disconnected. This is while the controller is connected and responding through the other SCP .exe files.

No program or game will recognize that there is a controller connected (whether wired or bluetooth).

Before I installed the program, if I look in Windows at "Set up USB game controllers" it was listed as Playstation 3 Controller. If I go there now, after installing the program, there is no controller listed.

So, controller is connected and responsive - but not detected by Windows, therefore unable to be selected as an input device in any program. It cannot be configured through Windows USB controller setup because it doesn't show in the dropdown menu, even though it is listed in Device Manager. My BT dongle is listed as compatible.

This is an awesome thing to be available for free! I just need some help to figure out this last thing, thank you!

SOLVED: Typing this post up helped me figure it out - just had to uninstall the XBOX 360 Controller listed under USB Devices and let Windows reinstall, all is well. I think something was left over. I'll leave the post in case someone else has a similar issue.

Sponsored links

Users browsing this thread: 1 Guest(s)