Stretched 3D graphics with normal 2D HUD?
#1
I've come across a weird thing, not sure how common it is, or if it's just what's to be expected (though I don't see how really).

As far as I know, PS2 games are 4:3. I've just started using 1.5.0 dev 3314 and it's been a huge upgrade from 1.4.0 for a bunch of games, but now something weird is happening. For both Xenosaga I and Persona 3 FES (the only games I've tried so far) the HUD is in the proper 4:3 aspect ratio, as I'm playing in that aspect ratio, but the 3d graphics of the game are stretched vertically, as though it's in widescreen but being squished to 4:3. But the game is originally in 4:3, so that's why I'm confused. 

When I go into the GS Window settings and change the aspect ratio to 16:9, the 3d graphics are as they should be, albeit in widescreen, but then the HUD is squashed. I've attached some screencaps to show.

I've done a bunch of Googling to see if anyone else has come across this issue, but can't seem to find anything quite like it.

I've added the PSCX2 Configurator plugin and have used the "Download Config" option for both games, but nothing I see seems to be the issue (to my meager understanding).

I personally don't care to play in widescreen, as I'm very much content in 4:3. I just enjoy the upscaling and crisp polygons, haha.

Any help would be greatly appreciated! Thanks!


Attached Files
.jpg   xenosaga1-normalHUDstretched3D.jpg (Size: 605,05 KB / Downloads: 256)
.jpg   xenosaga1-squashedHUDnormal3D.jpg (Size: 480,35 KB / Downloads: 261)
Reply

Sponsored links

#2
This looks like a widescreen patch is in effect. I am not familiar with when, but I think a widescreen patch was added at some point between 1.4.0 and now. Can you check in the System menu that Enable Widescreen Patches is on? If so, try turning it off and rebooting the game.
Reply
#3
(11-23-2019, 06:22 AM)pandubz Wrote: This looks like a widescreen patch is in effect. I am not familiar with when, but I think a widescreen patch was added at some point between 1.4.0 and now. Can you check in the System menu that Enable Widescreen Patches is on? If so, try turning it off and rebooting the game.

Hmmm, just gave that a shot like you said and unfortunately not a thing changed. Been scratching my head at this one for a few hours. I mean I could just deal with a squashed UI, I guess, but it's not ideal.

EDIT:

OK! SO! I did some more digging and FINALLY found a thread on here with someone who had some similar issues and he found that the last dev release where there were NO issues like this was dev 2342. So I downloaded that one and it works!
Reply
#4
The very next build was a bulk import of widescreen patches from Devina's archive. I still think it's highly likely the issue was from the patch being added, but if not having the patch present at all is the best solution, that's fair enough too.
Reply




Users browsing this thread: 1 Guest(s)