Stuck at 70% speed on almost every game
Hello. I know this forums gets a lot of posts like mine. People complaining how their rigs are good and their emulator is slow or doesn't work.
I'm just going to start by saying that my rig is not amazing. It's a bottleneck build for today's games and should handle PCSX2 pretty well.
I will also note that I'm an indie game developer and I'm familiar with how games are optimized.

Finally, I'll throw out my specs:
Processor: AMD FX 6300 (6 Core @ 3.5 GHz)
GPU: AMD Radeon r7 260x 2GB (128 bit data bandwith)

The game I was trying to play was Ratchet and Clank. What I have realized is that my game will run at about 60-70% of the speed, no matter what my resolution, mipmapping or texture filtering settings are. This leads me to believe my GPU does it's work just well. I even turned on forced FXAA in shader settings, no difference. I could see the improvement in edge graphics, but the fps didn't suffer whatsoever.
Because of that, I imeddiately assumed the problem is caused by the processor. But... It's a good processor!  Huh

So what I did is used the game's optimization method in my advantage.
Culling is a process in which games don't draw polygons (models, terrain etc...) unless the camera is faced in the direction of these polygons. Seems logic, right? Why waste processing power to render something you can't even see? So I assumed the game would be much slower if I looked at some mountains. And... It was! As soon as I look into the sky, or a wall, the performance jumps to over 300%. So, a bit over 180fps. That's much more than the original 40 I was getting.

So, since PCSX2 has so much graphic settings you can tweak, my question is: Are there any processor based settings we can tweak? Or maybe, is there something I'm not aware of?
In advance, thank you.
- Ziphold

Edit: Forgot to mention I use the developer build. Also, these are my settings:
[Image: jAgQV1U.png]

Sponsored links

Try enabling fast texture invalidation in the hw hacks menu. IIRC that one helps this game. If it's not enough, then try enabling MTVU. If you still can't get full speed, try moving the EE clock rate to -1 or -2. If it's still slow then it just means your processor isn't fast enough (the ratchet and clank games are pretty demanding). Those FXs overclock easily though.

Users browsing this thread: 1 Guest(s)