Stuttering issues with Castlevania: Lament of Innocence.
I'm using version 1.5.0-dev-1396. The game is having heavy stuttering using the Open GL and DX11 backends. I've got a GeForce GTX 660, and a Corei5 4570S. 8 Gigs of DDR3 RAM.

I've changed the settings up a lot in the GPU plugin, and have no trouble hitting 60 VIs. The stuttering happens regardless of how high or how low my enhancement settings are, even with them turned off I get this issue. I changed the blending setting to Medium(I had it on High before) see if that helps and it didn't. Interlacing's on auto as I don't really know what setting to use there.

I've got it on a 7200 RPM Hitachi HD that's got plenty of space(over 700 gigs left). I've tried so much stuff. I dunno what to do here. Can anyone help? Do y'all need any more info?

Sponsored links

what do the ee% & gs% say when you get stutterings ?
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
Doesn't seem to correspond to the EE/GS percentage as it happens at any percentage. It happened a couple times at 50some odd % EE and less than 20% GS, but I've had higher percentages with no stuttering.
If none of the percentages are reaching 100% or close, then there's 2 possibilities

1. Your GPU driver is getting hammered (unlikely if changing the graphics settings, like the native x# makes no difference) I would try using native resolution and setting the blending accuracy to Basic or Off just to be sure.

2. You have something else running in the background on your computer which is hammering your CPU.
[Image: ref-sig-anim.gif]

Do you have MSAA turned on?
Quote: I changed the blending setting to Medium(I had it on High before)
high require an ultra-top-class PC. Did you try none.
'Cause a fair bit of people replied to me, I'll be replying to points made rather than users.

1. I've tried with all image enhancements off. I even just double checked the internal res, and also tried adjusting my power settings for CPU and GPU to prefer maximum performance when running PCSX2. No dice.

2. DX11 has the same trouble as Open GL, so I don't think the blending mode is the issue.

3. I run my system fairly lean, plus it's a newish install of Windows 10(Done days before the final cutoff for the free upgrade). That said, I monitored my CPU usage while playing PCSX2 and did not have any issues on that front. Watched the graphs and everything. I don't think any of my cores hit above 50% for more than a little bit.

My AV was not running at any of the times I've had this stuttering, either. It's been persistent for days.

Edit: I watched some footage recorded from a PS2 just now. It seems the original game can stutter, but only under certain conditions... and I was getting it for the most part randomly(I seem to always have trouble right after loading a save and appearing in the save room and certain hallways in the House of Sacred Remains. Otherwise, it's random as hell). None of the conditions it reliably stuttered on in the video apply to me, either.

Damn if this isn't confusing. I might have to dig out my PS2 and test this on it, but it's not exactly easy to reach...
Played a different game. Mega Man X8. Like... two to four stutters in one section of the first stage. Otherwise, it was flawless.

I'mma dig out my PS2 in the next few days and test my copy of LoI(I do play it on ISO, but I confirmed the stutters happened on disc before trying ISO on the first place). If it still happens, I'll report back.
Since you mentioned heavy stuttering I doubt it could be the sole cause, but my general experience (at least with modern Windows systems where Vsync tends to be enforced through the DWM) has been that if you leave Vsync off in the GS window settings, any semblance of frame pacing goes out the window and you end up with a constant and annoying judder. Maybe double-check that just to be sure.
Vsync is off, and I don't think it was ever on.

Users browsing this thread: 1 Guest(s)