Sudden controller problem TS2
All of a sudden, whenever I go into a level on TimeSplitters 2, my character will keep turning right. I have no idea why, as it worked fine at first, then I switched to playing FFX for a while, popped in TS2 again and there the bug was.
I'm using a USB 360 pad, with just the standard plug-ins that come with PCSX2 0.9.8.
It seems as if LilyPad thinks I booted the game with the right analog stick pressed slightly to the left: therefore, I keep turning right when I'm not putting any pressure on the analog stick.
It's definitely the emulator that is causing this problem: there's no such issue with any other program. I even booted my N64 emulator into GoldenEye (with the 2 controller control-type preference mapped to the analog sticks) with PCSX2 running TS2 in the background. TS2 would have the problem, whereas GoldenEye wouldn't, no matter what (including booting GoldenEye first, then PCSX2).
Is this LilyPad acting up? Or is there any type of button combination that I can press in-game to recalibrate the controller, or would re-installing the emulator be of any help? Any advice would be greatly appreciated, as currently, I'm unable to play one of my favourite games of all time and that's kind of bugging me.

Sponsored links

Did it work correctly before? What PCSX2 settings? plugin settings?
Core i5 3570k -- Geforce GTX 670  --  Windows 7 x64
Had the same problem and almost made a post here and youtube vid about it.. rebind ur keys. My characters was leaning towards the left for all my games FFx-2, XII and tekken (less noticeable) but when i was making screenies i notices i binded -X Axis with two keys or something.. Think it happened when i was binding L3 or something but it definitely solved my game. I redid everything, binded only essentials ignoring L and R3 and all went well.

Users browsing this thread: 1 Guest(s)