Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Suikoden IV - water lines on hardware rendering
#1
Hi,
When I use the Hardware Rendering mode, I get some water glitch, take a look - https://imgur.com/CQWAdr7

The issue occurs only on the HW mode, not SW, but on software mode everyting looks soo bad.
My internal resoultion is 1080p
Reply

Sponsored links

#2
try align sprite hack.
what do you mean by "My internal resoultion is 1080p" ?

How did you configure your internal res ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
(10-03-2020, 11:03 PM)jesalvein Wrote: try align sprite hack.
what do you mean by "My internal resoultion is 1080p" ?

How did you configure your internal res ?

I think he means 3x Native resolution(~1080p) in gsdx settings.
Reply
#4
Quote:I think he means 3x Native resolution(~1080p) in gsdx settings.


Yes, that was exactly what I meant.

Tried align sprite HW hack and it didn't work.
Screenshot with HW hack: https://imgur.com/a/Inl8xcI
Reply
#5
Do you get this only when upscaling ?
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#6
I had a similar issue like that in God Of War. Those lines were under my character everywhere I walked. It was a side effect of scaling the image above Native resolution. I also saw something similar in DragonBall Z Budokai Tenkaichi all over the ground.

Press f9 to temporarily change to software mode and press again to go back. If the issue goes away in software mode I'm betting its a side effect of the scaling.

2 things fixed it for me in that game. If you are scaling your image, maybe it will help you.

Changing the resolution to -1 or +1 different native resolution size.
or
I enabled Merge Sprite hardware hack, and set Round Sprite to either Half or Full.

Setting the resolution to Native might also fix it, but you probably don't want to use Native resolution on account of how it looks. Might as well just use software mode if your gonna use Native.
Reply
#7
(10-03-2020, 11:03 PM)jesalvein Wrote: try align sprite hack.
what do you mean by "My internal resoultion is 1080p" ?

How did you configure your internal res ?

(10-05-2020, 09:10 AM)DarkDream787 Wrote: I had a similar issue like that in God Of War. Those lines were under my character everywhere I walked. It was a side effect of scaling the image above Native resolution.

Press f9 to temporarily change to software mode and press again to go back. If the issue goes away in software mode I'm betting its a side effect of the scaling.

2 things fixed it for me in that game. If you are scaling your image, maybe it will help you.

Changing the resolution to -1 or +1 different native resolution size.
or
I enabled Merge Sprite hardware hack, and set Round Sprite to either Half or Full.

Setting the resolution to Native might also fix it, but you probably don't want to use Native resolution on account of how it looks. Might as well just use software mode if your gonna use Native.

The issue does go away in the software mode.
Unfortunately none of those hardware hack didn't work.
The lines are visible on every resolution except Native.
Reply
#8
(10-05-2020, 09:04 PM)Welti Wrote: The issue does go away in the software mode.
Unfortunately none of those hardware hack didn't work.
The lines are visible on every resolution except Native.

It would be easier to make suggestions if you took a couple screenshots of your video settings.

Do you have Enable 8-Bit textures checked in?
Are you using FXAA which can be found in shader options?

Try turning those on if they are not enabled.

Only other suggestion I have without knowing all your current settings is if none of that helped, then try changing Half Pixel Offset to Special (Texture)
Reply
#9
half-pixel offset - normal(vertex) is the only hw hack i have to use to remove the black lines at 3x native resolution.
allow 8-bit is off, large framebuffer is off, everything else at default.

nvidia 1060

edit* im also using latest dev build, could be the difference.
i tested both 4:3 and 16:9 with widescreen patch enabled, no difference.
Reply




Users browsing this thread: 1 Guest(s)