Swing Away Golf D-pad sensitivity
I've been playing Swing Away Golf on PCSX2 recently and when I'm trying to set up a shot left or right of the pin (to account for wind or whatever), the spot I'm set to shoot to only moves in huge intervals, whereas on a PS2 I can get nearly microscopic differences. It causes the accuracy of a shot to suffer heavily by essentially only offering a small number of spaces to hit to.

It's a little odd since D-pad doesn't typically have sensitivity. I am using a PS2 controller with a USB adapter (I believe most programs read it as "Twin USB Joystick" or something), but I've also tried just using the keyboard and the same thing occurs. The FPS is normal, hovering right around 60. Is this a known problem with other games? I've personally never encountered it.

I'm using pcsx2-r5875 with lilypad-r5875. I own the disc and made my own image with Isobuster/DIC and they match Redump.

Sponsored links

I'm not 100% certain if the dpad has sensitivity, but if you configured your controller while the "analog" light was off, your dpad will be mapped to the joysticks. I had this issue in some PS1 games, where I forgot how I configured it, so I had a hyper sensitive dpad from it being configured as the main joystick when the analog is turned off.
Unfortunately, it's not that. D-pad is mapped to the "POV hat" while analog is mapped to the respective stick. And for this game, the analog sticks control camera, not shot location.
Maybe it is some clamping/rounding issue of the movement. Have you tried increasing clamping accuracy (by using Full/Preserve sign whatever is at the bottom) and/or using other rounding modes?

What happens if you press Shift+Tab (slow motion) and then use the Dpad?
Thanks for offering up some solutions! I tried changing the EE/IOP and VUs clamping settings to all different stuff, and nothing changed anything any which way. If I hit Shift+Tab and use the D-pad, it moves by all the exact same intervals - the height I'm hitting to is always the same down to the decimal point. It's quite an odd occurrence, really. I thought that at least the slow motion should change it v__v
So no more guesses as to what this is? With the way it runs right now, the game really isn't playable. It's pretty hard to play a golf game only being given 2 or 3 different shots you can make - that's literally how large the intervals of movement are. When the wind is blowing 4 MPH in one direction, you need to adjust for it slightly, and right now, that's simply not a possibility. And without that possibility, the idea of getting close to the hole and setting up nice shots disappears, and that's what golf is all about.

Bit of a shame =/
problem is you're probably the only to have this game here on our forums.
means no dev or bug squad member would be able to reproduce the "bug" to eventually sort this out.

just to be sure : what if you map your d-pad to keyboard keys ? Just to rule out the possibility of a bad signal sent by your pad...
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
he already tried that :/

Can you please show the second tab of lilypad settings where you map all your buttons?
Perhaps your combination of controller driver and USB adapter doesn't allow for pressure sensitivity functions to operate? Do you have any other games to test? uh...Gran Turismo?

I'm using a DualShock3 with the SCP drivers with the lilypad plugin provided with the SCP drivers and d-pad pressure sensitivity works great.
Here are my controller settings.
I hope that's a good picture.

My D-pad isn't the issue since this trouble also occurs with the keyboard. I'm not much for Gran Turismo - I own A-spec but don't really play it - but I have played quite a bit of Ridge Racer V, and I can make incredibly slight turns. I just tested it with my keyboard and it works fine. I don't have my controller handy right now but from my memory, it works with the controller as well. The DualShock and the keyboard have worked the same throughout in my experience, and both are having the "sensitivity" issue (if that's what it is) with Swing Away Golf, so I don't think it's one or the other, it seems to be the game. The same settings also just worked with Ridge Racer V.

Oh, and I also just tried Swing Away Golf without the controller plugged in, and it behaves the same way. I really think it has something to do with the game.

Users browsing this thread: 1 Guest(s)