Tales of Destiny 2 Graphics Glitches
Finishing ToD: DC (thanks to whomever provided that FMV fix patch by the way) made me want to give ToD2 a try again. When I tried ToD2 on 1.0.0, I had some graphics glitches. I read in the announcements that the glitches were fixed in the latest version of GSD. I downloaded the latest subversion revision of PCSX2, but the glitches remained. I tried googling for information regarding how to fix the glitches, but I saw no useful information.

The glitches are:
- no fonts in battle (all numbers and text including character and enemy names, hp/tp, and damage)
- pulling up the menu screen makes the background go completely black in the first town until moving to a new area
- pulling up the menu screen makes the background mostly dark in the overworld until entering and exiting the first town

GSD settings are (it is unclear whether the check mark is half or the filled box is half, so I am assuming the check mark is half and the filled box is full):
DX11 Hardware
Auto Interlacing
Native Resolution
Full Texture Filtering
Intrinsic Half Logarithmic Z and Alpha Correction
Hardware Hacks MSAA 2X Half Sprite Half WildArmsOffset (in 1.0.0 no Hardware Hacks were enabled so feel free to ignore this as the source of the problem

Do I need to wait for the GSD plugin in the new PCSX2 release before these glitches will be fixed? Are there plans on getting them fixed? Is something weird with my NVIDIA 550 Ti?

Any help appreciated.

Sponsored links

Try software mode
Core i3 9100f 3.6Ghz
nvidia GT 1030
pcsx2 version-1.3.1  

Still surfing with Browser?, Try the pcsx2 forum App !
(09-10-2013, 05:10 PM)Brock lessner Wrote: Try software mode

if it is a problem with gsd's use of the gpu and i have to go software, is there a plan to fix that bug?
i would be willing to wait
i remember the bug that prevented tales of legendia's dialog boxes being displayed in hardware mode was fixed in the 1.0.0 version of pcsx2's gsd plugin
when you say "latest version) which pcsx2 revision did you try ?
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go
(09-10-2013, 06:36 PM)jesalvein Wrote: when you say "latest version) which pcsx2 revision did you try ?

at the time of the post it was 5726
that is now one revision behind the current

Users browsing this thread: 1 Guest(s)