Tales of the Abyss control issue
This is quite possibly the oddest thing that I've seen happen since I've started using PSCX2. This is on my lap top, since it makes a handy portable gaming device, and I haven't noticed this issue pop up on the desktop in the slightest.

When playing Tales of the Abyss and I go into the menus, things work fine. However, whenever I go into the sub-menus, like Artes or the System menue to save or check the journal to see what I need to to next, it seems that Lilypad or my controller itself stops working. With the other two games I regularly play (Phantasy Star Universe and part one of Dot Hack), this doesn't happen. No problems going into menus or sub menus there. I've tried restarting PSCX2, rebooting the game, and even restarting my entire computer, but it still happens. Even took a poke at Lilypad with no success. The game boots up fine, and there are no errors reported in the console, even when the controls fail. I am currently using the most recent stable version of PCSX2, and, quite frankly, I have no idea what's going on. Any suggestions?

And yes, I know the general work around would be just don't go into the sub menus, but...Anyone that's played a Tales of game knows those menus are rather important XD

Sponsored links

Indeed odd.
Can you still please show the console output after you observed the issue? Just that we get some more information.

The exactly same iso, bios and pcsx2 version work on the pc? Maybe some corruption during transfer of the bios or iso to the notebook? Backtransfer still works?

How do you know that the game is still running and the is the controller? Maybe the core freezes during submenu but the spu keeps playing bg music? If emulation freezes there would be as well no input feedback.
Oh man, I remember such a bug in this game but that was at least 6 years ago.
Please make sure to use the latest versions of PCSX2 and plugins. Get them from the build bot.
Also make sure to disable all speed hacks and generally use the default configuration or a preset.
I had this happen long ago as well... either it was a bad PCSX2 version / setting, or it was cheat-related. Not sure.

Are you running any cheats by any chance?
AMD Ryzen 5 3600 @ 3.60~4.20 GHz | Corsair Vengeance LPX 32 GB (2x16GB) DDR4-3200
MSI GeForce GTX 1660 Super @ 6 GB | Samsung 980 1TB | Windows 10 Pro x64 (22H2)
Alright, I figured it out. Thanks for the suggestions guys! Really put me on the right track there. It wasn't the speed hacks doing it. It was actually a setting that I had to change for PSU to run properly, setting the EE/FPU Advanced Recompiler Options to Nearest instead of the usual Chop/Zero. Set it back to Chop/Zero, all issues vanished.

And no, I wasn't running cheats X3
Oh guess that was it then lol. I never figured out what I did to fix it back in the day.. guess I fixed it by accident. Tongue Glad you got it working now at least.
AMD Ryzen 5 3600 @ 3.60~4.20 GHz | Corsair Vengeance LPX 32 GB (2x16GB) DDR4-3200
MSI GeForce GTX 1660 Super @ 6 GB | Samsung 980 1TB | Windows 10 Pro x64 (22H2)

Users browsing this thread: 1 Guest(s)