Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Tekken 5, always 60fps but not totally silky smooth
#1
Hi all, been playing tekken 5 alot lately, and this little issue quite bothers me
my specs [email protected] , 970, 16G ram
using pcsx2 from 1.2.1 stable vesion untill latest
not using any ee or vu cycle hack except MTVU
for video plugin, always dx11 and IR testing from 3x to 5x,
hardware hack enable with align sprite to prevent infamous vertical black line for namco titles

so i always got 60fps running , it just ingame there's occasionally little stutter here and there
coz i get more fond of this great and beautiful game after playing more and more
this micro-stuttering just sort of gets abit annoy and not fully pleasant experience
i even used software (msi ab) to monitor the frame time though and all seems alright.

so does anybody here feels the same or having same question ?
or could it be its actually the game itself is meant to be running like this even on console ?
or maybe i just simply missed something ?

thanks for any answer and idea in advance
Reply

Sponsored links

#2
Are you playijng the game from an ISO or straight from the disc?

Also please upgrade to version 1.4.0, 1.2.1 is no longer supported.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#3
(03-26-2016, 01:33 AM)refraction Wrote: Are you playijng the game from an ISO or straight from the disc?

Also please upgrade to version 1.4.0, 1.2.1 is no longer supported.

always using iso , tried too put it on ssd but same
and yes normally using 1.4.0 and this 1.2.1 just use it to test whether have different result,
i tried some 1.5.0 dev build as well via orphis build bot and this minor stutter always there, couldn't figure out the reason really
Reply
#4
if you have your console open while you're playing, see if its putting any lines in the console when the micro stutters happen. Sometimes when it is recompiling one of the VU programs that can cause a stutter, but it will also put a message in the console window to say it has done that.

If that is the case, you could try SuperVU and see if that's any better, or try without MTVU to see if that helps, although that may bring your speed down, so it could be worse lol
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#5
Did you enable VSync?
"Monge~!"
Reply
#6
(03-26-2016, 09:41 AM)Akio Wrote: Did you enable VSync?

no no , never used pcsx2 vsync nor driver forced vsync at all,
i'll try monitoring console log to see if anythings shows up as refraction said ,
report back later
Reply
#7
It's probably the same problem Dolphin has: shader compilation. You will notice that the small pause happens when a new effect loads (the shader has to be compiled, and that can takes a few frames), and if you make it appear again, the stutter won't happen.

In Dolphin's case, compiled shaders are saved in a folder and are valid until you use a different build of the emulator. At that moment, they are discarded because they could be incompatible. The devs are working on ubershaders, a collection of all shaders that can be generated, to avoid stuttering globally.

In PCSX2, they aren't stored and I don't remember devs talking about this issue, if I remember correctly. So I guess shaders have to be compiled again when you use the emulator again. Please, correct me if I'm wrong about PCSX2.
CPU: Intel Core i7 7700k @ 5GHz
GPU: Gainward GTX 1080 GLH
Motherboard: Gigabyte Aorus GA-Z270X-Gaming 5
RAM: G.Skill Trident Z RGB DDR4 3866MHz 16GB CL18
Monitor: Dell S2716DG
OS: Windows 10
Reply
#8
Shaders are compiles at initialization I believe, it's more likely the VU program causing the stutters.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#9
(03-26-2016, 11:22 AM)AcidRains Wrote: no no , never used pcsx2 vsync nor driver forced vsync at all

You should enable it.
"Monge~!"
Reply
#10
(03-26-2016, 01:18 PM)masterotaku Wrote: It's probably the same problem Dolphin has: shader compilation. You will notice that the small pause happens when a new effect loads (the shader has to be compiled, and that can takes a few frames), and if you make it appear again, the stutter won't happen.

In Dolphin's case, compiled shaders are saved in a folder and are valid until you use a different build of the emulator. At that moment, they are discarded because they could be incompatible. The devs are working on ubershaders, a collection of all shaders that can be generated, to avoid stuttering globally.

In PCSX2, they aren't stored and I don't remember devs talking about this issue, if I remember correctly. So I guess shaders have to be compiled again when you use the emulator again. Please, correct me if I'm wrong about PCSX2.

(03-26-2016, 05:14 PM)refraction Wrote: Shaders are compiles at initialization I believe, it's more likely the VU program causing the stutters.
Actually HW renderer shaders are compiled at first use. However the driver can cache the compilation. Normally shaders are rather small. And we compile them once by GSdx init. So if you hit F9, it will discard previous results. Otherwise it ought to be transparent.
Reply




Users browsing this thread: 1 Guest(s)