Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Text missing on menus - The Urbz Sims in the City
#1
Hi everyone, 

I am new here, I have never used PCSX2 before, so I am a total noob to this. I really had the urge to play this game again, but unfortunately I no longer have access to a PS2 at this very moment, so I have the emulator. 

Most settings in PCSX2 are left at their default settings, I have only really changed the controller settings and that's about it. 

The game seems to launch without issues from the original disk. There does appears to be some text missing which makes the game very difficult to play.

Please see screenshot 1 attached, the menu seems to not be rendering correctly, I can hear the swooping sounds when I try to get through the menu, but I just don't see any changes.

If you look at screenshot 2, it gives you an idea for how the menu should be rendered. Is there something I can try here to see if I can fix it?

Thanks in advance Smile


Attached Files Thumbnail(s)
       
Reply

Sponsored links

#2
Please post the contents of the emulog.txt file after the problem occurs. The file can be found in "My Documents\PCSX2\logs" for the installer version or in "PCSX2\logs" for the portable/binary version.

Please make sure to enclose your emulog in code tags like so (remove the empty space on the closing code tag!):
[code]
Pasted emulog goes here
[ /code]
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#3
Code:
PCSX2 1.4.0-20160105132032- compiled on Jan  5 2016
Savestate version: 0x9a0b0000

Host Machine Init:
Operating System =  Microsoft Windows 10 Education (build 17134), 64-bit
Physical RAM     =  16322 MB
CPU name         =  Intel(R) Core(TM) i7-6700K CPU @ 4.00GHz
Vendor/Model     =  GenuineIntel (stepping 03)
CPU speed        =  4.006 ghz (8 logical threads)
x86PType         =  Standard OEM
x86Flags         =  bfebfbff 7ffafbbf
x86EFlags        =  2c100000

x86 Features Detected:
SSE2.. SSE3.. SSSE3.. SSE4.1.. SSE4.2.. AVX.. AVX2.. FMA

Reserving memory for recompilers...

Loading plugins...
Binding   GS: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\gsdx32-avx.dll
Windows 10.0.17134
Binding  PAD: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\lilypad.dll
Binding SPU2: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\spu2-x.dll
Binding CDVD: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\cdvdGigaherz.dll
Binding  USB: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\USBnull.dll
Binding   FW: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\FWnull.dll
Binding DEV9: C:\Program Files (x86)\PCSX2 1.4.0\Plugins\DEV9null.dll
Plugins loaded successfully.

(GameDB) 9693 games on record (loaded in 109ms)
HLE Notice: ELF does not have a path.


Initializing plugins...
Init GS
Windows 10.0.17134
Init PAD
Init SPU2
Init CDVD
Init USB
Init FW
Init DEV9
Plugins initialized successfully.

Opening plugins...
Opening GS
Opening PAD
Opening SPU2
Current Renderer: Direct3D11 (Hardware mode)
Opening CDVD
* CDVD: Opening drive '\\.\G:'...
* CDVD: setSpindleSpeed success (11080KB/s)
* CDVD: IO thread started...
* CDVD: KeepAlive thread started...
* CDVD: Disk Type: Double-Layer DVD
* CDVD Disk Open: DVD, Single layer or unknown:
* * Track 1: Data (Mode 2) (2178400 sectors)
Opening USB
Opening FW
Opening DEV9
McdSlot 0 [File]: C:\Users\me\Documents\PCSX2\memcards\Mcd001.ps2
McdSlot 1 [File]: C:\Users\me\Documents\PCSX2\memcards\Mcd002.ps2
Plugins opened successfully.
EE/iR5900-32 Recompiler Reset
Bios Found: Europe  v01.60(04/10/2001)  Console
BIOS rom1 module not found, skipping...
BIOS rom2 module not found, skipping...
BIOS erom module not found, skipping...
(UpdateVSyncRate) Mode Changed to NTSC.
(UpdateVSyncRate) FPS Limit Changed : 59.94 fps
# Initialize memory (rev:3.63, ctm:392Mhz, cpuclk:294Mhz detected)

PlayStation 2 ======== Hard reset boot
ROMGEN=2001-1004, IOP info (CPUID=1f, CACH_CONFIG=0, 2MB, IOP mode)
<20011004-175839,ROMconf,PS20160EC20011004.bin:11520>
# Total accessable memory size: 32 MB (B:2:8:0) (363:2:7c30)
# TLB spad=0 kernel=1:12 default=13:30 extended=31:38
# Initialize Start.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize User Memory ...
# Initialize Scratch Pad ...
# Initialize Done.

EE DECI2 Manager version 0.06 Jul  4 2001 16:03:45
 CPUID=2e20, BoardID=0, ROMGEN=2001-1004, 32M

(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLES_529.08;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = PAL
ELF (cdrom0:\SLES_529.08;1) Game CRC = 0x25C3948E, EntryPoint = 0x00100008
(SYSTEM.CNF) Detected PS2 Disc = cdrom0:\SLES_529.08;1
(SYSTEM.CNF) Software version = 1.00
(SYSTEM.CNF) Disc region type = PAL

IOP Realtime Kernel Ver.0.9.1
   Copyright 1999 (C) Sony Computer Entertainment Inc.
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
loadelf: fname cdrom0:¥SLES_529.08;1 secname all
loadelf version 3.30
Input ELF format filename = cdrom0:¥SLES_529.08;1
0 00100000 003c05e4 .............................................................
Loaded, cdrom0:¥SLES_529.08;1
start address 0x100008
gp address 00000000
# Restart Without Memory Clear.
# Initialize GS ...
# Initialize INTC ...
# Initialize TIMER ...
# Initialize DMAC ...
# Initialize VU1 ...
# Initialize VIF1 ...
# Initialize GIF ...
# Initialize VU0 ...
# Initialize VIF0 ...
# Initialize IPU ...
# Initialize FPU ...
# Initialize Scratch Pad ...
# Restart Without Memory Clear Done.
Memory available from OS is 27533 KB
sce_fileio: unrecognized code ff

IOP rebooted - ProDG Tuner will not work

Get Reboot Request From EE
ROM directory not found

PlayStation 2 ======== Update rebooting..

PlayStation 2 ======== Update reboot complete
cdvdman Init

IOP Realtime Kernel Ver. 2.2
   Copyright 1999-2002 (C) Sony Computer Entertainment Inc.
Initializing SIF...
Reboot service module.(99/11/10)
cdvd driver module version 0.1.1 (C)SCEI
Load File service.(99/11/05)
Multi Threaded Fileio module.(99/11/15)
iop heap service (99/11/03)
Exit MultiStream V6.2 Thread Load
USB Driver (Version 1.1.0)

Binding with stream.irx version 7
Trying to bind regular callback
Waiting for INTERNALrpc.serv != 0
Trying to bind load complete callback
Waiting for LOADCOMPLETErpc.serv != 0

Done Binding
(UpdateVSyncRate) Mode Changed to PAL.
(UpdateVSyncRate) FPS Limit Changed : 50.00 fps
************************************************************************
SOUND_DisplayStats
========================================================================
VERSION: MultiStream V7.0
  SPU buffer mode currently in V6.2 mode.
  SOUND_ResizeSPUBuffer ACTIVE.
  SPU RAM buffers can be different sizes to their stream IOP buffers.
  NOT SCREAM COMPATIBLE (modify ms_switches.h and recompile IOP to enable)
INFO: SPOT FX
Memory Allocated at IOP Address: 0x4be00
Allocated space for 50 SFX

INFO: FILE
Memory Allocated at IOP Address: 0x4b900
Allocated space for 30 SFX

INFO: STREAM
Stream Channel 0 allocated: IOP Addr=0x74d00 IOP Size=0x10000, SPU Addr=0x0, SPU Size =0x10000
Stream Channel 1 allocated: IOP Addr=0xa9900 IOP Size=0x10000, SPU Addr=0x0, SPU Size =0x10000
Stream Channel 2 allocated: IOP Addr=0xb9900 IOP Size=0x10000, SPU Addr=0x5010, SPU Size =0x10000
Stream Channel 4 allocated: IOP Addr=0x4d900 IOP Size=0x8000, SPU Addr=0x0, SPU Size =0x8000

************************************************************************
usbcam: max usbcams = 1, pack = 1, multi isoc = 8
usbcam: mic sample = 0, mic size = 0, frame size = 20480
usbcam: DMA thpri = 49, SIFRPC thpri = 50
------ Entering parseCommandLine()
Argc: 1, Argv: 004D7744
Argv[0]: cdrom0:¥SLES_529.08;1
---------------------------------------------------------------------
>>>> WARNING: SOUND_GetMIHInfo
End offset (0x10b0)is not >= to half the track size (0x2000)!!
(TrackSize = 0x4000)
Forcing end offset to be 0x2000
You may want to recreate data with FPacker..
---------------------------------------------------------------------
>>>>>WARNING: SOUND_SetStreamParent
Stream 0x2 SPU buffer size (0x10000) is larger than half IOP buffer size (0x4000)
Changing Stream 0x2 SPU buffer size to 0x4000
Note that all following CHILD streams will automatically be changed also
---------------------------------------------------------------------
>>>> WARNING: SOUND_GetMIHInfo
End offset (0xd20)is not >= to half the track size (0x2000)!!
(TrackSize = 0x4000)
Forcing end offset to be 0x2000
You may want to recreate data with FPacker..
---------------------------------------------------------------------
---------------------------------------------------------------------
>>>> WARNING: SOUND_GetMIHInfo
End offset (0x1f80)is not >= to half the track size (0x2000)!!
(TrackSize = 0x4000)
Forcing end offset to be 0x2000
You may want to recreate data with FPacker..
---------------------------------------------------------------------
---------------------------------------------------------------------
>>>> WARNING: SOUND_GetMIHInfo
End offset (0xd20)is not >= to half the track size (0x2000)!!
(TrackSize = 0x4000)
Forcing end offset to be 0x2000
You may want to recreate data with FPacker..
---------------------------------------------------------------------
---------------------------------------------------------------------
>>>> WARNING: SOUND_GetMIHInfo
End offset (0x1f80)is not >= to half the track size (0x2000)!!
(TrackSize = 0x4000)
Forcing end offset to be 0x2000
You may want to recreate data with FPacker..
---------------------------------------------------------------------
Closing plugins...
Closing DEV9
Closing FW
Closing USB
Closing CDVD
* CDVD: KeepAlive thread finished.
* CDVD: IO thread finished.
Closing SPU2
Closing PAD
Closing GS
Plugins closed successfully.
Reply
#4
1 - give latest GIT build a try
2 - try OGL renderer
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply
#5
That seems to have fixed it.... OGL hardware rendering sorted it Smile
Out of curiosity, what is the latest GIT build? where/what do I need to do to get that?

Thanks for the help though Smile
Reply
#6
https://pcsx2.net/download/development/dev-windows.html
CPU : I7 2600K Oc'ed @ 4.2Ghz
Mobo : Intel P67 southbridge
GPU : NVIDIA Geforce GTX 750 Ti
RAM : 6 Go
Reply




Users browsing this thread: 1 Guest(s)