The Higher we are the farther we fall
I wish I could sum up my problem in just one question, but here is a few complaints, I have been noticing of lately that maybe some of you can help me with :

1. I upgrade from PCSX2 0.9.6 to 0.9.8 only to find FFX going from 60 fps to 30 fps (see the problem) on my nice 1920 x 1200 monitor. Now, I know size is not every thing, but I tend to like my fullscreen picture. Even if I cant get it with surround sound.

2. Upon noticing this huge drop in fps I realize that the reason for it is not the emulator but the video plugin upgrade instead so naturally, I downgrade the plugin back to 0.1.14[ssse3]. And naturally, the next thing breaks like the "ESC" key no longer gets me back to PCSX2 window (lets caulk this one up to just plain annoying, where is that next save point), so say goodbye to clean exits, or maybe pausing the game surfing the net then getting back into it. you know the usual cool stuff. Now I get to do a hard crash with ALT+TAB.

3. Oh so now is when I talk about why I did this to begin with and what annoys because it still happens from time to time. At random some time after I start the game but sometime before I finish exiting the game, the game decides to just crash, and black screens / purple screens on me and everything is frozen can't do a thing (Any you thought the BSOD was bad look out now the PSOD is rolling out). Nothing works. Oh but get this I can remote desktop in and I can kill everything and work on my desktop just fine, so I think PCSX2 just took out my video card. Just a minor detail. Who needs video anyways. Not like you really need that to work. So in order to fix this I have to reboot my computer which is a server board from 06s mind you yeah its made it past its expiration date.

If your still here and got any ideas or think you can help this is some shot and specs:


CPU: Dual Processor 5160s
GPU: NVIDIA GeForce 7950 GX2 (Driver Version [Because someone is going to ask]

I don't know if this slows things down but I use Daemon Tools to mount an .iso and then read from there. Instead of reading direct. Dont ask why just do. Or I read direct if I have yet to make the iso. I usually make the .iso so I don't have to spin my own disk.

I was using keyboard for input but will try using a gamepad shortly but doubt that will add issues.

Ahh now for the show if it matters ... see looks normal to you that's what I thought so any suggests, thoughts, ideas, anxieties, yeah, well, whatever just leave them in the box, below right there, yep right there!

Sponsored links

run it from the internal iso loader. it's recommended. disable all speedhacks and run it in native resolution to get a unadultered performance result. then up the options til it runs at an enjoyable resolution at full speed. nothing more you can do. probably.
1) Known, the newer PCSX2 emulates more stuff (there were missing polygons and some discoloration which are now properly emulated) thus naturally speed went down. I don't get the rest of the full screen stuff you talk about since the size of your screen has nothing to do with the speed you get with PCSX2, only the internal resolution you set in GSdx has.

2) There are a couple of options in lilypad to fix that, mainly "safe full screen exit on escape"

3) Your graphics drivers are problematic and/or your graphics card has issues, PCSX2 just triggers the problem but is not the cause.
[Image: newsig.jpg]
Okay but I went down from full speed 60 fps to about half at my full screen resolution and I always have used native resolution, but if you don't believe me believe my pictures ...

Old GSdx9 nice 1920x1200 with 60 fps or 50 fps (PAL):


New GSdx9 with low (30) fps at 1920x1200 but has 60 fps at native res in window mode


Now personally I could care less about having the best GSdx on the market except this "ESC" problem I mention above. So what I was really looking for a fix too was is there an older GSdx that can be integrated into the 0.9.8 package? Personally I like it when all the components were independent but now the video and PCSX2 are so tightly wound that changing the plugin in causes issues in overall compatibility this is a programmer no, no! I should know because I am one!
I just told you a workaround for the ESC issue...
Also what you show there is both games running at native internal resolution. The resolution you have set at 1920x1200 is simply the window res not the res the textures are rendered. The control for that has moved in the new PCSX2 to the GS tab of the PCSX2 configuration
Edit: OK it seems like a vsync issue, check the GS tab and toggle Vsync on/off or do it from your graphics card drivers
[Image: newsig.jpg]
try updating your Graphics drivers, Next, update to the latest GSDX plugin (if you haven't already, i noticed you said you went back to the old one).
Disable all speed hacks, Are you getting full speed? if not continue.
During your slowdowns, what does is say in the title bar of PCSX2? (run in window mode for this one) Is ee% at 80%+? your CPU is being limited.
enable EE cyclerate hack up to 2 (you can try 3, i believe it works fine in FFX) try again, did you see an FPS improvement?
GS% up around 80%+? your video card is limiting you

I just reread your post and saw you said it gets 60FPS in windowed mode, So like Bositman said above. It sounds like a vSync issue. check inside your nVidia control panel and make sure it isn't somehow set to 30hz as a maximum refreshrate.

Did you fix your BSOD/PSOD issue? BSOD is usually a driver issue, I can tell you the PSOD IS a driver/hardware issue with your graphics card. run thelatest nVidia driver and have it perform a clean install (you'll lose any advanced settings in your driver config)
Intel Core i7-8700k @5ghz
G.Skill 16GB DDR4 @3600mhz
GeForce GTX 1080 8GB
Windows 10 x64
ohh yeah CoyoteWAN. you're a programmer? kewl. but can't manage to get your computer in a stable shape.
ohh and the compatibility was raised. so what's the point dealing with old code. and foo.. thinking about 6 year old hardware not to keep up with additional work. most guys here use newer hardware.
So I must agree the third is my card being itself the other two is still something we should be able to solve first off You place an old GSdx plugin in there and sorry but the whole "Safe fullscreen exit on escape" does not work for me. Even though I do have it checked off. Although I do get a nice bong!

You know the other thing that does not work the vsync solution I tried it a few ways even forcing it from the card, but I don't think that is the answer, because I used window mode and get this. I love 16:9 so I started at 800:450 it got 60 fps not too bad but 1200:675 well that only 57 fps, and 1600:900 well that was in the 45-50 fps range ... and I am not even fullscreen yet! Notice a trend!

I think I will stick with mr ancient video plugin with hopes someone can find a way to get me out cleanly.
As you increase your internal resolution you put more stress on your video card, Which is why you lose FPS. I also have noticed that it adds stress to the CPU, but not much.

I also have noticed your card is a GX2, just so you know. PCSX2 doesn't use SLI, so you are only using on GPU on that card.
Have you tried reinstalling/updating your drivers yet? could help you a bit.

EDIT: Link to drivers
Intel Core i7-8700k @5ghz
G.Skill 16GB DDR4 @3600mhz
GeForce GTX 1080 8GB
Windows 10 x64
(12-19-2011, 10:49 PM)CoyoteWAN Wrote: I love 16:9 so I started at 800:450 it got 60 fps not too bad but 1200:675 well that only 57 fps, and 1600:900 well that was in the 45-50 fps range ... and I am not even fullscreen yet! Notice a trend!

You're adjusting the internal rendering resolution which has nothing to do with output aspect ratio.
Please simply use the x2 or x3 scaled setting from the newer GSdx versions.
These are also the only ones that will properly support full screen or Vsync settings.

Users browsing this thread: 1 Guest(s)