The "Time Crisis" series on PCSX2 r5051
Hey guys, I had wanted to put this in here and not the bug reporting thread because for these games to work it requires the use of speedhacks and I wanted to see if anyone had any insight into this before I posted a thread in the bug reporting section.

Crisis Zone appears to be perfectly playable, with some minor issues. There are some minor issues with shadows during cutscenes using hardware rendering, and there is an effect which is present for about 2 minutes during one of the later levels which will decimate the GPU (tested some 100 revisions ago), but is completely playable using a software renderer (I'll get a dump in the GSdx thread later).

However, I made this thread to focus primarily on the Time Crisis II and Time Crisis III games. These games will not boot/hang unless the EE Cyclerate hack is enabled and set to 3, and will have skippy/distorted audio unless the VU Cycle Stealing hack is set to 3 (and this will not fix skippy/distorted audio inside of the cutscenes). The games must also be played in software rendering or else a bad (what seems like a greyish postprocessing filter?) filter will be set over the screen. In a late level in Time Crisis III, there are some bad effects with fire/smoke even with software rendering.

I had played Time Crisis III all the way through. I had played II for only about five minutes, but it seems to suffer from the same exact problems.

Some important info:

PCSX2 r5051 package from here:
CPU: i5 2500k at stock (3.3Ghz, 3.7Ghz Turbo)
GPU: ATI HD 6950 (OC'ed to a core clock of 900Mhz)
OS: Windows 7

I'll get some images up of the bad "filter" in HW rendering.

Edit: Alrighty, there they are. The first two are TCII, with HW rendering first. Then TCIII, with HW rendering first.
Edit: Also forgot that to mention that on skipdraw=1000, it seems to have no effect on HW during the game except for the menu screen.

TL;DR: The game suffers from audio problems during cutscenes, requires speedhacks to boot up, and is slow during gameplay because it needs these hacks. The need for VU cycle stealing causes the image to bob in such a way that it can't be remedied by interlacing methods, and sometimes the audio corrupts even in game unless the frame limiter is off. It also suffers from some bad effects using a HW renderer.

Attached Files Thumbnail(s)
Want to contribute? Don't know how? Check out the PCSX2 Wiki page!

Keep safe with MyWOT.

I have everything...

Sponsored links

Try the cdvd speedhack instead of all the other hacks.
We just fixed these games, too :/
HW renderer whiteness can be hack fixed by skipdraw 1 (or 2, try them both)
[Image: newsig.jpg]
With the fast CDVD hack, the game will still not load without EE Cyclerate = 2 or higher (which is the same for without the hack, only I had skipped ahead to 3 before without testing 2). The audio problems are still present, and the whiteness is not fixed by any level of skipdraw.

Also, as a clarification, the EE Cyclerate = 2 hack isn't needed for gameplay, but is needed for menu screens and the such to load/not hang.

This also seems to be the case for the most recent revision posted, r5062.
Want to contribute? Don't know how? Check out the PCSX2 Wiki page!

Keep safe with MyWOT.

I have everything...
Hey guys, I just wanted to bump this and say that Time Crisis 2 and 3 are still acting the same as before, and still require extensive tweaking of speedhacks to make the game boot and to have the game run at the correct speed and with uncorrupted audio in-game. The audio of the cutscenes is still broken, and will loop and become corrupted for a second before looping and the such. Changing the VU Cycle Stealing settings and changing the framerate with async sound settings seems to affect this, however.

Also upon revisit, I saw that the whiteness on hardware rendering only happens on the Dx11 mode, and not the Dx9 mode.

Edit: This is on r5186.
Want to contribute? Don't know how? Check out the PCSX2 Wiki page!

Keep safe with MyWOT.

I have everything...
Edit: Oh, yeah, the game I'm really messing around with right now is Time Crisis II, but both 2 and 3 appear to use the same engine.

Another bump with just a bit more information after tweaking with Dx9, speedhacks, and the such I failed to do months ago. Also nice little screenshots and information about my system and the such.


Another thing to note is that you do seem to get a correct game speed in-game if any speedhacks you used to boot the game are disabled. The major flaw I did while testing way back when, I believe was assuming that EE Cyclerate was needed for the game to not freeze (or did it freeze with it off? I honestly do not remember) and that it didn't likely effect the speed anyways. However, you need it if you go back to the menus or anything like that. You need EE Cyclerate = 2 or to transition from a cutscene. You also need it to transition into a cutscene. Disabling VU Cycle Stealing while in-game will screw up music effects before the music dies off (although the music can come back periodically, it will still be screwed up).

There's also a minor graphical bug on Dx9 hardware mode that I couldn't manage to remove using skipdraw or the other hacks. The only thing that skipdraw = 1000 seems to do is remove HUD aspects. It seems to be some broken postprocessing filter (screenshots included). This happens even in native resolution (which is the resolution of the game when the screenshots were taken).

Another thing is that the details which display when a stage is cleared do not show unless EE Cyclerate = 2 or higher, making it impossible to progress (screenshot included) unless enabled.

Also, while this is unrelated, the CPU usage that this early Time Crisis engine takes is ludicrous. It seems to take up about twice the postprocessing power when that broken graphical effect is present, but that may be coincidence because it is a filter which shows up in an outside or large inside area (since it is set back).


Some important reference information:

PCSX2 r5190 package from here (includes r5186):
CPU: i5 2500k OC'd @ 4.6Ghz (3.3Ghz, 4.6Ghz Turbo)
GPU: ATI HD 6950x2 (These should both have their cores at 840Mhz)
OS: Windows 7

GSdx 5190
LilyPad svn (r5112)
SPU2-X r5172
cdvdGigaherz (r4488)

Non-default options:

Various other speedhacks/no speedhacks
Slowmo: 100%
Turbo: 100%

Tested both TimeStretch/Async
Volume: 36%
Latency: 150ms

Video (Direct3D9):
Auto interlacing
Textile filtering half-checked/full-checked
Allow 8-bit textures
Alpha Correction
Logarithmic Z
Some other hacks and such used during testing, usually not enabled.

Attached Files Thumbnail(s)
Want to contribute? Don't know how? Check out the PCSX2 Wiki page!

Keep safe with MyWOT.

I have everything...
Okay, some points:

Older games often work worse on PCSX2 (and the real console, too).
They have bugs that result in inefficient code that waits on things it wouldn't have to, or they hammer some register
as fast as they can for a status update to happen.
Since PCSX2 needs to emulate the correct PS2 behaviour in the important cases,
it gets slower and slower the more of these bad things come together.

Try to use just the recommended speedhacks but play with the CDVD speedhack, see what happens then.
Well, the issue wasn't just that it was slow. Most of the time, I run at near-fullspeed.

It's the issues with the cutscenes, the audio, and that the not-recommended speedhacks are required for menus and audio and the such.

With all the recommended speedhacks enabled and no "not recommended" hacks (Enable INTC Spin Detection, Enable Wait Loop Detection, Enable fast CDVD, mVU Flag Hack, MTVU), the game will not boot at all.
Want to contribute? Don't know how? Check out the PCSX2 Wiki page!

Keep safe with MyWOT.

I have everything...
Please enable all the console logs and check if you get a "sce1394SbEui64(): failed -1" error when it fails booting.
(In that case your BIOS is too old, unfortunately. Too old means that due to our primitive firewire support makes
games hang with this error on firewire enabled BIOSes.)
Ah, yeah, I have "sce1394SbEui64(): failed -1" in there.

So, besides having to use the speedhacks to get it to boot, is there anything else I can do to fix the audio issues/that minor graphical issue?

Also, would this apply only when booting the game or does this explain all other hangs? Does this also affect the audio and as such explains why cutscenes and the in-game audio are messed up?

Also, is there any idea as to when I would see this kind of error for my BIOS fixed?
Want to contribute? Don't know how? Check out the PCSX2 Wiki page!

Keep safe with MyWOT.

I have everything...

Users browsing this thread: 1 Guest(s)