Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
The Urbz: Sims in the City - Graphical glitches in hardware mode
#1
Hello,

I've spent most of tonight trying to play The Sims Urbz, but much to my dismay, the game doesn't like hardware mode all that much. I've tried 1080p and 720p resolutions, but both yield the same issues. I have googled and I managed to find a couple of old threads enquiring about these problems, but there were no known solutions other than software mode. I come here now hoping that there might be potential fixes to these glitches.

The missing menu is the phone menu, and the black lines persist throughout the game (excluding the main menu and loading screens), as far as I can tell.

Specs:
i7 3770 @ 3.4GHz
GTX 950
16GB RAM
Windows 10 Pro (x64)

I'm attempting to run the US version that I ripped to an ISO file. PCSX2 version 1.5.0-dev-2948-gdabc99f46. Thanks!


Attached Files Thumbnail(s)
                       
Reply

Sponsored links

#2
Tried it with OpenGL?
Reply
#3
(02-26-2019, 03:29 AM)StriFe Wrote: Tried it with OpenGL?

OpenGL fixes the phone GUI, but the lines persist.
Reply
#4
Try one of the HW hacks and/or a different texture filtering option.
Reply
#5
(02-26-2019, 05:13 AM)CK1 Wrote: Try one of the HW hacks and/or a different texture filtering option.

So I've tried messing around with the hardware hacks. Good news, the lines are corrected by a half pixel offset (special texture), but the game also requires a half pixel offset on vertices to render textures correctly. Is there no way to get both? 

   
Reply




Users browsing this thread: 1 Guest(s)