Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
The same Tony hawk Underground Problem
#1
First of all I'm actually pretty stoked to have made an account and being able to talk to people who actually know more about this stuff than I do. I usually have to help everyone I know with this sort of thing.

And second, I'm aware that this same issue has been asked before, but the thread was a year old and it didn't seem the user was all that interested/capable of figuring things out, and therefore the issue was unsolved.

In Tony Hawk Underground when large portions of the map are on screen, or 'in front of the player' there is a huge fps drop, to somewhere between 20-40fps from 60. Now I'm pretty certain this has to do with cpu bottlenecking when it decides to load the areas of the map far off in the distance all at once. The problem is that you have to disable multithreading to run this game or it hangs in the loading screens. I'll put my specs at the bottom, but I've got a quad core processor, and maxing out 1/4 of it and suffering from fps drops just seems really unfair. Because of this I'm looking for an advanced setting or possibly editing some pcsx system files to get around the multithreading issue, or lower the draw distance in the game, or SOME fix to get this game to run at 60fps.

I've tried toying with the different speed hacks, gpu plugins, and their settings, and switching from preset to preset. One of the reasons i'm sure its cpu bottlenecking is that I've run the game in 3x resolution with 16x anisotropic filtering and other such options and gotten the same, 60fps and then heavy drops as when i ran at native resolution with no filtering.

I'm running windows 7 x64
my cpu is an amd fx 4350, OC'd to i think 4.6GHz (maybe 4.8)
8GB ram
my gpu is an amd 260x 2GB
and my pcsx2 version is 1.2.1

Help me Someone-anybody, you're my only hope.
Reply

Sponsored links

#2
Do you use non-default settings?
What are fps, ee%, gs% during slowdowns?
Reply
#3
(08-13-2015, 11:45 PM)willkuer Wrote: Do you use non-default settings?
What are fps, ee%, gs% during slowdowns?

Right now i'm on the 'aggressive' preset across the board. The fps here is at 40 here as i'm standing still, facing the bulk of the map from the edge, and if i were to move and turn it drops lower, but i cant really take a screeny and steer at the same time.

those values are at the top of the big screen shot.


Attached Files Thumbnail(s)
       
Reply
#4
Please put preset to the second lowest value (I think its '1 - safe (faster)') And make the same screenshot (in-game) again.

Please post gsdx plugin settings.
Reply
#5
(08-14-2015, 12:05 AM)willkuer Wrote: Please put preset to the second lowest value (I think its '1 - safe (faster)') And make the same screenshot (in-game) again.

Please post gsdx plugin settings.

Alright the first couple screenshots i had forgotten to reset the gpu settings for troubleshooting, so they had some filtering and i think they were at 2x. but for this one i made the edit below and set the preset to '2-safe(faster)'


Attached Files Thumbnail(s)
       
Reply
#6
also have tou tried the MTVU speedhack?
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#7
MTVU breaks tony hawks.


What happens with the fps if you increase the internal resolution from native to 2xnative? What happens at 3x, 4x native?
Reply
#8
(08-13-2015, 11:38 PM)jhammerstrike Wrote: The problem is that you have to disable multithreading to run this game or it hangs in the loading screens.
(08-14-2015, 12:14 AM)refraction Wrote: also have tou tried the MTVU speedhack?

Yes i have tried it. it hangs on the loading screens.

(08-14-2015, 12:18 AM)willkuer Wrote: What happens with the fps if you increase the internal resolution from native to 2xnative? What happens at 3x, 4x native?

at 2x and 3x i get the exact same behavior. fps drops are no lower. and i still run at 60 if i turn around and face a smaller part of the map
Reply
#9
Sorry you already validated that there is no gpu bottleneck. I forgot that.

Please post the full emulog after you observed the problem.
How does EE cycle rate hack at medium or maximum position affect fps?
Reply
#10
(08-14-2015, 12:25 AM)willkuer Wrote: Please post the full emulog after you observed the problem.
How does EE cycle rate hack at medium or maximum position affect fps?

Alright i played around a minute with the slider on the left and then again with the slider on the right. i also tried to pay attention to the ee number at the top while i did so.

there was almost no difference in fps, if i had to make a contrast, i would say that i got to 60fps less often while i had the slider at maximum. either way the number bounced between 60&85, no discernable difference. they both had the same standing fps from the starting position, around 35fps.

the attached emulog should have what you want, however i'm not sure when it overwrites that with the new version, so it may just have the information from the latest run, in which case that was the ee cycle hack at maximum.


Attached Files
.txt   emuLog.txt (Size: 2,86 KB / Downloads: 96)
Reply




Users browsing this thread: 2 Guest(s)