Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Tiger Woods 2004 missing course textures (PCSX2 1.6.0)
#1
Good afternoon everyone. I would like to thank the staff involved in PCSX2 for its creation.

I am currently trying to play through Tiger Woods PGA Tour '04 again. The game runs at full speed and looks beautiful for a game from 2003-2004 running at 1440p resolution. Again, thank you for this excellent emulator.

Computer specifications:
Windows 10 x64
Intel 7700K
Nvidia 1080 GTX SLI w/456.71 driver
M.2
32 GB RAM
PCSX2 1.6.0

The problem I'm experiencing isn't the typical graphical glitch that most users experience where textures are missing from characters. I'm missing textures on the actual course, and only on the edges of the screen. I will probably ignore this and play through the game regardless of if I can fix the issue or not.

I have tried the graphics fixes from the FAQ and also anything I could find elsewhere online. I have tried all sorts of different options, rendering resolutions, etc.

               

Any help is very much appreciated.

Thank you.
Reply

Sponsored links

#2
(10-12-2020, 11:35 PM)TurbodTalon Wrote: Good afternoon everyone. I would like to thank the staff involved in PCSX2 for its creation.

I am currently trying to play through Tiger Woods PGA Tour '04 again. The game runs at full speed and looks beautiful for a game from 2003-2004 running at 1440p resolution. Again, thank you for this excellent emulator.

Computer specifications:
Windows 10 x64
Intel 7700K
Nvidia 1080 GTX SLI w/456.71 driver
M.2
32 GB RAM
PCSX2 1.6.0

The problem I'm experiencing isn't the typical graphical glitch that most users experience where textures are missing from characters. I'm missing textures on the actual course, and only on the edges of the screen. I will probably ignore this and play through the game regardless of if I can fix the issue or not.

I have tried the graphics fixes from the FAQ and also anything I could find elsewhere online. I have tried all sorts of different options, rendering resolutions, etc.



Any help is very much appreciated.

Thank you.


It's the widescreen code. All TW PGA games have that issue, since the addresses in the widescreen archive all start with a "0".  If you change all addresses(or maybe just the render fix address?) to begin with a "2" instead, it will work. For example, the 16:9 widescreen patch for USA version of 2004 should look like this:

//Gameplay 3D
patch=1,EE,207C3880,word,3F400000 // 3F800000

//Menu 3D
patch=1,EE,205A7C80,word,3F400000 // 3F800000

//Game Play Render Fix
patch=1,EE,207C3890,extended,44800000 //44000000
patch=1,EE,207C3898,extended,40000000 //3f800000

Once I did that, I could even use a 32:9 patch and that works as well (although 32:9 needs a value adjustment with the render fix, but HUD is still stretched of course)

   

Here is some footage of 05 I made a few months ago in 21:9. Notice how the issue is no longer there: https://youtu.be/rFivwxmxFOE?t=7637
Reply
#3
The problem seems to be caused by applying the widescreen patch. The game isn't rendering textures that it believes are outside the player's field of view.

For some reason it takes awhile for the widescreen patch to be removed after deselecting the option. I had to uncheck the option and the game removed the patch after a couple of rounds.

I hope this helps someone else in the future.


Attached Files Thumbnail(s)
   
Reply
#4
Holy smokes, looks like you posted while I was writing my post!

Thank you SO MUCH. I think you just took my TW04 experience to the next level!

I overwrote the data in the 64F9781E.pnach file (NTSC version of Tiger Woods PGA Tour 2004) located inside of Documents/PCSX2/cheats_ws.zip with the data you supplied above. The old file had '0' exactly where you said there should be '2'. Works like a charm.

Again, thank you very much for the assist.
Reply
#5
Another question. If you take a look at the attached comparison you'll see that the widescreen patch alone doesn't stretch the golfer out horizontally. Is there something I can change in the code to keep the widescreen and the texture rendering while not stretching the golfer out?

I appreciate the help.


Attached Files Thumbnail(s)
   
Reply
#6
(10-13-2020, 02:41 AM)someother1ne Wrote: It's the widescreen code. All TW PGA games have that issue, since the addresses in the widescreen archive all start with a "0".  If you change all addresses(or maybe just the render fix address?) to begin with a "2" instead, it will work. For example, the 16:9 widescreen patch for USA version of 2004 should look like this:

//Gameplay 3D
patch=1,EE,207C3880,word,3F400000 // 3F800000

//Menu 3D
patch=1,EE,205A7C80,word,3F400000 // 3F800000

//Game Play Render Fix
patch=1,EE,207C3890,extended,44800000 //44000000
patch=1,EE,207C3898,extended,40000000 //3f800000

Once I did that, I could even use a 32:9 patch and that works as well (although 32:9 needs a value adjustment with the render fix, but HUD is still stretched of course)



Here is some footage of 05 I made a few months ago in 21:9. Notice how the issue is no longer there: https://youtu.be/rFivwxmxFOE?t=7637

Hi, I'm having the same issues as OP but lack the knowhow to fix it - I have to change files in the cheats_ws folder according to OPs later post? This game was working fine for me until this week, I have changed some graphical settings when I tried another game but I have changed everything back so I don't know what's causing the issue.
Reply
#7
quick way around it is to disable Widescreen patches from the menu, otherwise you'll need to dig in to the cheats_ws.zip and remove the original patch then put your own in the cheats_ws folder
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#8
(11-27-2020, 02:46 PM)refraction Wrote: quick way around it is to disable Widescreen patches from the menu, otherwise you'll need to dig in to the cheats_ws.zip and remove the original patch then put your own in the cheats_ws folder

Thanks for your quick reply, I can't find 'Disable Widescreen patches' anywhere in my settings. I've searched google for where to find it to no avail.
Reply
#9
(11-27-2020, 04:40 PM)Mr Mosstin Wrote: Thanks for your quick reply, I can't find 'Disable Widescreen patches' anywhere in my settings. I've searched google for where to find it to no avail.

Although I have managed to fix it by resetting all settings to default and going through first time startup again. Porblem solved!
Reply
#10
for future reference it's under the PCSX2 menu (first one) and it's called "Enable Widescreen Patches" you just need to untick it
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply




Users browsing this thread: 1 Guest(s)