ToA freeze problem

I recently got myself a ps2 emulator and have been playing my
old tales of the abyss game. It all worked fine upto Choral Castle, where the game is now freezing in battles (then crashes). I read around and noticed that x3 speed hack could be the problem, here's the real problem though: I'm using save states, not the ingame save.. so I kinda saved a few times on that file while using x3 hack trying to get past the crashes.

Now if the speed hack is the problem, can anyone give me a savestate/memory card with a nearby save? I have one other savestate but it's on the Tartarus, WAY back in the game.

Sponsored links

Normally, you should be able to save the game with a real save point if you manage to get to one. Then it should work out... sort of.
Whenever I try to save at a ingame savepoint, it just sits there trying to find the memory card, that's why I had to use savestates instead.
Well slap me silly will ya.

I fixed a proper memory card, avoided every battle while backtracking to the save point and saved. Restarted the game and loaded it from the startmenu.. I haven't tried much but I did one fight and no freezes!

Hopefully it'll stay ok during the Arietta fight.

Users browsing this thread: 1 Guest(s)