Tomb Raider Legend PAL Graphical Glitch
At the start of the first level of Tomb Raider Legend PAL (SLES-53908), there is a very annoying graphical glitch. When moving the camera around, the plants in the area jumps (on a regular basis) from normal looking (Screenshot A) to garbage looking (Screenshot B).

When standing still or there is no camera movement, the plants remain either normal looking (Screenshot A) or garbage looking (Screenshot B). Once there is movement/camera movement, then the glitch starts again.

Maybe the glitch gets triggered when the camera is at a certain position, angle, distance from the plants? Most game engines usually switches from high detail to low detail objects depending on camera distance to the object.

I might be wrong, but it seems in this game that PCSX2 can't properly switch from the high detailed to lower detailed (or vice versa) version of the plants, displaying "garbage" instead. I wish the plants gets "locked" at the normal looking version ...

The exact same problem exists in Tomb Raider Anniversary PAL (SLES-54674), for example in Croft Manor, the stacked crates switches from good to garbage looking.

Thanks for taking the time to read this post!


Sponsored links

In order to help you further with your problem, please make sure the following are all provided.
  • Your hardware specs - CPU, Graphics Card, Memory, Operating System.
  • The version of PCSX2 you are using.
  • Any non default settings you are using.

Thank You.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Apologies for the reply delay

Here is the same glitch in action in Tomb Raider Anniversary


I have tried every setting and option combination there is(defaults, non-defaults you name it) and tried PCSX2 1.00 to the latest SVN build with no success. The glitch remains to this day. Don't get me wrong, the game runs smoothly and it is not a game braking glitch (just a slightly annoying glitch). When switching to software mode, the glitch disappears.

However, when running in software mode, some new nasty effects appears to the right side of the screen (also in TR Anniversary):


I am running PCSX2 on a NOTEBOOK with the following specs:

8GB of 1.33GHz Dual DDR3 RAM
Intel Core i7 Quad 2700QM (Sandy Bridge) 2.00GHz
GeForce GT 540M 2GB VRAM
Operating System Windows 7 x64 Professional V6.01 Build 7601 Service Pack 1

With the above specs, so far most of my games runs decent with no complaints. I have all the latest drivers installed. A minor (or is this a major) glitch that no one has reported before?
Hmm, question, do the texture errors in hardware mode only happen with things in the distance? because it looks like mipmapping to me, which isn't supported in hardware mode.
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
I tested it again just now, not necessarily with stuff in the distance, it always seems to happen only when running around or moving the camera many times. When standing still or not moving the camera, the texture remains glitched or displays correctly. Once there is movement you get the idea...

As you can see in the Tomb Raider Legend screenshots, the character is standing near those plants, and then it glitched.

Users browsing this thread: 1 Guest(s)