Trouble PLaying Online
Hello. I followed the directions here to play games online. The particular game that I'm trying to play is battlefield 2. I've dumped the bios from my ps2 using freemcboot and another tool. I ripped the isos for battlefield 2 and Network Access Disk v 4.0 using Alcohol 120% and the ps2 setting. I then tried to use pcsx2 to get the discids as that guide says you can. I was only getting the last 2 characters though for both discs. The rest were zeroes (Any idea why?). I then tried to run the discid util on my ps2, but my fat old ps2 wont read burned discs (laser may be going bad). I was able to run it off of a pendrive. It recognized the battlefield 2 disc id just fine, but for the network adapter it just returned all zeroes. I'm running pcxsx2 9.8 and using the giga raz dev9 plugin in bridged mode. I tried patching the NAD 4.0 disk with all zeroes, but I get the -864 DNAS error. The network creator on the battlefield disk has a graphical issue that makes it unusable. I was able to use the network configuration from my ps2 (It's DHCP, but strangely that doesn't seem to be the issue) in bf2. It gets past DHCP then just hangs at DNAS. No error, it just freezes there. I played the game on my ps2 this morning so it still works. I have Winpcap 4.1.2. Any idea what's going on? Thanks!

EDIT: Using Windows 7 64bit if that matters.

Sponsored links

I'm still messing around with this in addition to my other thread on the graphical issues I'm having. I've copied the error generated when the game hits the DNAS screen (then freezes) to pastebin. "WARN : pbd->length not alligned..." is a recurring error. Does anyone know what might cause this?

CPU: Core 2 Duo E7300 @2.66GHz
Memory: 4Gb DDR2
GPU: Nvidia GeForce GTX 260 Core 216
OS: Windows 7 64bit

EDIT: Tried killzone also. I realize their servers are down but I thought maybe it would get through DNAS. It just prompts that it wasn't able to connect to network. Gives a similar pbd->length not alligned error. Has anyone had luck with either of these two games? I must be missing something...
I'm having another sort of issue regarding the network access disc. [see attachment]
I press X when I'm at the screen you see here, and it gives me the error -864
Has anyone here managed to get ps2 netplay working without the use of a legit physical network access disc? I'm sure a lot of the netplay users have.
The most recent post in this thread is more than 8 months old. Please create a new thread and refrain from posting in threads older than 8 months in the future. Please also review the forum rules. Thank you.
CPU : AMD Ryzen 7 3800X
Mobo : Asus PRIME B450-PLUS
GPU : NVIDIA GeForce RTX 3070
RAM : 16 Go

Users browsing this thread: 1 Guest(s)