Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Trouble getting high fps. 20-30 fps average in game.
#1
I have tried various things to increase the fps. It gets to about 60 fps during cutscenes and intros but drops in game to about 20-30.

Games I've tried: God of War 2, Ncaa Football 2004, Jak and Daxter - The Precursor Legacy

I dont have top of the line pc by any means but I think I should be able to play games a little bit better

Specs: AMD A8-7600 Radeon R7 ,10 Compute Cores 4C+6G @3.10 GHZ ,8GB Ram.
Overclocked @ 3.7 GHZ

Thanks to anyone who can help
Reply

Sponsored links

#2
Those are all really demanding games and your CPU is only average in single threaded performance.

What settings are you using?
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#3
(01-31-2015, 07:49 PM)Blyss Sarania Wrote: Those are all really demanding games and your CPU is only average in single threaded performance.

What settings are you using?

Ill just attach the images. Are you saying I should be playing less demanding games because they just won't be playable?


Attached Files Thumbnail(s)
                       
Reply
#4
Ahh, I see your problem.

In your second to last picture - you have synchronized MTGS enabled. Disable it.
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#5
(01-31-2015, 08:35 PM)Blyss Sarania Wrote: Ahh, I see your problem.

In your second to last picture - you have synchronized MTGS enabled. Disable it.

I would ask "how does one miss the text right below that thing that says it's potentially VERY SLOW?!" but then again there are people who feel the urge to tick everything regardless so i'll go home now.
Reply
#6
(01-31-2015, 08:35 PM)Blyss Sarania Wrote: Ahh, I see your problem.

In your second to last picture - you have synchronized MTGS enabled. Disable it.

Alright, thank you. That boosted it to about 35-40 fps. Any other suggestions? Is it just the games and I can't get that higher?
Reply
#7
What are your graphics plugins settings?

You also might try ticking the VU slider up a notch(but beware it can cause glitches and "fake" fps)
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#8
(01-31-2015, 08:46 PM)Blyss Sarania Wrote: What are your graphics plugins settings?

You also might try ticking the VU slider up a notch(but beware it can cause glitches and "fake" fps)

I've also been messing around with different versions of pcsx2 like .96 and .98, but I'm guessing that won't make a difference for fps. Moved up the VU slider so Ill see if that makes a difference as well    
Reply
#9
#1 - switch to D3D11 for renderer
#2 - Are you playing from disc? If so, make an ISO. The first section here will tell you how to make a good one.
#3 - older versions are generally faster, but less compatible. They are also not supported on the forum(only the latest stable and GIT builds are)
[Image: vwah44]
Gaming: Intel i7 3770k @ 4.2Ghz | R9 290 | 16GB RAM | 480GB(240GB+240GB RAID0) SSD | 3 TB HDD | 1 TB HDD | 500GB HDD
Server: AMD FX 6300 @ 4.4Ghz | GTX 670 | 16GB RAM | 240GB SSD | 320GB HDD
PCSX2 General Troubleshooting FAQ
Reply
#10
1. Alright, I switched the renderer. Im at about 60 fps right now, will keep updated to see in real gameplay though.
2. Im playing from iso, but I have the disk in currently. Ncaa Football 2004 doesnt seem to work with the iso or the disk. Maybe not compatible though
3. Ill stick to the newer versions then for support


60 FPS in game on Jak and Dexter !! I love you. Ive been trying for three months on my own. You helped in 5 minutes. Thank
Reply




Users browsing this thread: 1 Guest(s)