Trouble with pnach file - Monster Rancher 4
Hey guys!

So I've been revisiting some games from my youth, and I got around to Monster Rancher 4. Since the game experiences problems with disc swapping, allowing me to create new monsters to... ranch... I stumbled on a cheat which unlocked the entire monster book and lets me just pick a monster to revitalize. Seems pretty straight forward, but I've never worked with cheats before.

So I did some reading, and a lot of it didn't make sense to me, but after trying it, it seems to mostly be cleared up. Here's what I've got.

This pnach, as supplied on the "Post your pcsx2 cheats - patches here" thread
comment=Monster Rancher 4 NTSC-U(SLUS-20702)
//Fill book with all monsters

//Fill Gadget shop

So I don't mind having the gadget shop full, while I'm at it, so I left it in the pnach. I have tried it without the gadget shop bit. No luck
I went to the cheats_ws folder, created a text document, pasted the above into it, renamed the folder "0EF3697B.pnach" ensuring that I had extensions shown and wasn't accidentally naming it .pnach.txt

I start the game, and the console tells me "0 cheats loaded"

So I messed around with the code a bit, found a few tutorials on proper pnach structure and tried to add lines that were missing, to no avail. Tried renaming the folder "Cheats" without the underscore "ws" to no avail. I checked to ensure I didn't have // on the patch lines (which you can see from the original source, that I did not).

I'm competent in the tech world. I'm a professional in IT, but have zero programming experience. No need to break this down like I'm 5, but clear instruction on how to troubleshoot would be very helpful. What am I missing here?

Thank you
[Image: s8pOO2G.jpg]

Sponsored links

There should be a "Cheats" folder inside the PCSX2 directory. Put your pnach there.
Also ensure you are showing file extensions. Many times your file is actually named .pnach.txt
Intel Core i5-8600K @ 4.5 GHz
GeForce GTX 1080 SC2 Stock
ASRock Z370 Taichi LGA 1151 mobo
CORSAIR Vengeance LPX 16GB 2400 DDR4 RAM
SAMSUNG 970 EVO M.2 2280 500GB PCIe SSD
Indigo Xtreme Thermal Interface Material
Phanteks Enthoo Pro ES614P Black Steel Case
EVGA SuperNOVA 750 G2 220-G2-0750-XR PSU
Windows 10 64-bit
(08-24-2015, 06:27 AM)jlwmanagement Wrote: There should be a "Cheats" folder inside the PCSX2 directory. Put your pnach there.
Also ensure you are showing file extensions. Many times your file is actually named .pnach.txt

Hey jlw, thanks for the comments.

When I installed it came with a cheats_ws folder, I have attempted to use the folder as named, and in troubleshooting, I did rename it to simply "cheats"
Is the folder name case sensitive?

Additionally, It's definitely changing the file type. I ensured file type extensions are shown, and I can't manipulate the text file after I change the file type to .pnach, telling me that it has indeed changed the file type
cheats_ws are for widescreen patches. If there's no cheats folder then simply create a new folder named cheats. Then put your pnach file in there. Make sure the name is xxxxxxxxxx.pnach (x being the game's crc).
[Insert Witty Sig Here.]
I will try again tonight, but I had renamed the folder in my troubleshooting efforts. So at one point, the folder was "cheats" and contained the pnach with the correct file extension.

I'll let you know if I have any additional luck
I would suggest reinstalling pcsx2 to restore the folder structure.
(08-24-2015, 07:33 PM)willkuer Wrote: I would suggest reinstalling pcsx2 to restore the folder structure.

I think this is just a case of whether pcsx2 is portable or not, so the place where it looks for cheats changes. If it's portable, it's gonna look for cheats wherever the main executable is. If not, it should have a folder somewhere in documents.
Since both memcards are located at my documents and have their default names I just assumed he uses the installer version. Might be wrong but highly probable. If he uses the installer version and played a bit too much with folder names reinstalling would be a good idea.
Okay, I've uninstalled and reinstalled, and am given the same "cheats_ws" that I had before, and no "cheats" folder.

Should I try to download again? Perhaps I somehow got a messed up version? I'm not even sure where I downloaded it from.
I went back to the download page, and I have 1.2.1, and I definitely recognize the page. I got it from the source.

Why am I not getting a cheats folder like everyone else? And why does it not recognize the cheats I put in my cheats folder when I create one?

Users browsing this thread: 1 Guest(s)