Trying to get Pressure Sensitivity in 1.4.0
Hey everyone,

Now that I'm on break, I've gotten some time to get back into some games I've wanted to play.
Currently I'm playing Metal Gear Solid 2: Substance right now and planning on playing Metal Gear Solid 3: Subsistence right after this playthrough.
For those who are familiar with the series, you all know how beneficial pressure sensitivity is to core gameplay features within the games.
I am using a PlayStation 3 SIXAXIS controller for my controller, not a DS3.

I have tried both PCSX2 1.2.1 and 1.4.0 as my emulators. For my controller programs, I am using SCP. I have used both the latest SCP toolkit, the one taken from the GitHub repository they currently have, and the previous build (I assume), which the properties of the .exe say as version

With 1.4.0, I cannot tick (greyed out) DualShock 3 native mode under Game Device APIs under the LilyPad-SCP PAD plugin settings (tried both versions r5350 and r5875 to no avail). DirectInput is off  and XInput is turned off (with SCP installed, XInput could not be turned off as it kept crashing every time; I uninstalled SCP to disable XInput and then installed it again) but I still cannot enable DS3 native mode. It says it requires SCP XInput DLL, which I have in the directory of my PCSX2 1.4.0 executable. Under the Device Diagnostics box, the only available device is WM Keyboard with DirectInput and XInput both off. My SIXAXIS controller is visible under SCP Monitor and the Input tester shows pressure sensitivity within the face buttons (strangely the SCP's input tester does not respond to any controller activity when both PCSX2 1.2.1 and 1.4.0 are active). 
1.4.0 doesn't work with the two new or old SCP builds I'm using.

With 1.2.1, I have managed to achieve pressure sensitivity within MGS2. My current configuration consists of SCP's older build, the one without the toolkit (.exe says, and PCSX2 1.2.1. Both r5350 and r5875 versions of LilyPad-SCP PAD plugins can enable DS3 native mode with DirectInput and XInput disabled. The Device Diagnostics box within the PAD plugin settings shows WM Keyboard and DualShock 3 #1 devices. I am able to rebind keys under the Pad 1 tab of the plugin settings unlike in 1.4.0. In regards to how PCSX2 behaves, it does not crash as much as 1.4.0.
1.2.1 only seems to work with the older SCP build I have.

In both 1.2.1 and 1.4.0, XInput dll and LilyPad-SCP dlls are in their correct directories. 

My goal is to get pressure sensitivity on PCSX2 1.4.0.

Above are pretty much all my observations I have noted. Please let me know if there are any other details that would be helpful in getting this to work.


Edit: More relevant info.

Sponsored links

Users browsing this thread: 1 Guest(s)