Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Trying to get R&C to work smoothly is a nightmare
#1
Specs: 
Intel Core i5-4690K 3.50 GhZ 4 CPUs
8GB Ram
Nvidia GeForce GTX 960 4GB Ram
Windows 7
[Image: 7ObzSmC.png]

I'm trying to run Ratchet and Clank in PCSX2 (damn good game tbh) and I'm having a lot of issues to get it to run smoothly, and considering I want to speedrun the game in the future (and my ps2 is pretty much a brick at this point) it's not like I can afford myself to have more than some occasional slowdown.

When I boot R&C 1, I'm first greeted with some audio glitches then completely screwed textures, I'll get into this later. First let's do some testing (all the testing is done on the level Metropolis - Kerwan)
512x448|Auto|Interlaced Skipdraw:1


1- Speedhack custom  - EE: 1 VU:0 MTVU enabled ( Direct 3D11 hardware) (This is what I've been using this far)
Ingame
-Sound slightly glitched
-Textures screwed

Standing idle: Very rare speed drops, 100% speed constant
Playing the entire level from start to finish: Most noticeable moment was a drop in speed all the way to 70% when loading a relatively big zone, speed around empty parts was 100% (although I personally did notice some small slowdowns while doing things like collecting bolts, like they get to you slower than usual, it's noticeable). Parts where there were enemies had a constant speed of 80-90%, causing a noticeable slowdown too.

Any preset and combination has shown worse performance (1 and 2 MTVU balanced are slightly worse and 4,5,6 are increasingly worse) (MTVU not enabled will give me similar performance but won't show any changes in speed, idk why) I could have a 70% slowdown and it would say its 100% still. MTVU enabled preset 3 will give me a slightly better performance, less speed drops (still noticeable though) but fake speed reading.



I've tried to change anything in the audio settings but the glitched audio doesnt get fixed

I know screwed textures-> Enable mipmapping, so I tested it running in Software instead of hardware (Direct 3D11) and even though the textures are fixed, the resolution is really bad and the slowdowns are way more noticeable (its bad) and I've tried every other renderer and there are no differences (None doesn't even give me an image though)

It's really a pick your poison situation except Hardware doesn't even run the game smoothly.

I feel like I have tried everything and I can't seem to get anything better than that, could I have some help please?
Reply

Sponsored links

#2
What PCSX2 version are you using?
Reply
#3
(01-20-2018, 02:58 AM)CK1 Wrote: What PCSX2 version are you using?

1.4.0
Reply
#4
You need the latest v1.5.0 development build: https://buildbot.orphis.net/pcsx2/index.php
Reply
#5
Download the latest dev build here: https://buildbot.orphis.net/pcsx2/index....rev-v1.5.0
Reply
#6
Once you have the latest build from one of the links above, go in to the GSDX settings and make sure mipmapping is set to at least "basic"
[Image: ref_sig_anim.gif]
Like our Facebook Page and visit our Facebook Group!
Reply
#7
(01-20-2018, 03:07 AM)refraction Wrote: Once you have the latest build from one of the links above, go in to the GSDX settings and make sure mipmapping is set to at least "basic"

It's actually automatic now IIRC Tongue
Reply
#8
(01-20-2018, 03:01 AM)FlatOut Wrote: You need the latest v1.5.0 development build: https://buildbot.orphis.net/pcsx2/index.php

Damn, I like searched PCSX2 a few days ago and got 1.4.0 but this one is sooo much better, with my optimal preset I barely get slowdowns on unloaded parts (max 90%)

I don't know if this is normal behavior or there's a way to solve it so it really does no slowdowns but it's certainly way way better now, thanks!
Reply




Users browsing this thread: 1 Guest(s)