Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Trying to get the right settings for Shin Megami Tensei: Persona 4
#1
Hi. Currently running the latest build and it runs almost perfectly, even with Shiny Enemies (can't say the same for Persona 3 FES) but, I do want to crank it higher and add some AA to the game. Thing is when I DO add AA to the game, I see all kinds of graphical glitches that seem to be related to ground/wall textures looking like a rainbow or just crazy looking as you walk.  Lastly, I have a line at the top of character portraits. It's thin and not too distracting but it would be nice to get rid of it.

Menus look flawless and everything else is flawless and sharp at 6xnative.

My Emu settings are as follows:

EE/IOP:
Recompiler, Recompiler
Chop/Zero, Normal



VUs:
SuperVU Recompiler, SuperVU Recompiler
Chop/Zero, Normal


GS:
Defaults


Speedhacks Enabled:
EE Cycle is set to default as is Cycle Stealing
MicroVU hacks both used (this is a godsend)

Automatic Game Fixes:
Auto and not manual.


The GS:
D3D9

Auto Interlacing

6xnative

Bilinear Forced (tried PS2)

16x ASF

CRC Hack set to Full

Alpha Correction

Hardware Hacks on:

Preload Data Frame

Round Sprite is Full

Sprite is set to Half


My Basic Specs:

i7 7740x @ 4.7GHZ
32GB of Ram
GTX 1070 FTW 8GB
2TB SSD


I guess what I am really asking is: What would be good settings for AA/no graphical glitches?
I hope I don't sound too ignorant here for whatever reason. I just want to be steered toward a solution. So I wanted to register and see if someone here could give a bit of some help!
Reply

Sponsored links

#2
Switch to the OpenGL renderer. You won't be able to use MSAA, only FXAA.
Reply
#3
(01-31-2018, 08:01 AM)EmuSage Wrote: Lastly, I have a line at the top of character portraits. It's thin and not too distracting but it would be nice to get rid of it.
There's no solution for this issue currently.

(01-31-2018, 08:01 AM)EmuSage Wrote: I guess what I am really asking is: What would be good settings for AA/no graphical glitches?
I hope I don't sound too ignorant here for whatever reason. I just want to be steered toward a solution. So I wanted to register and see if someone here could give a bit of some help!
If you really want MSAA you should try the Direct3D11 renderer. It might remove the glitches.
Otherwise it's better to follow CK1's suggestion.

Using microVU instead of superVU and updating to the latest v1.5.0 development version of PCSX2 can help too.
Reply
#4
Thanks for the suggestions, guys. I'll download that build and toy with it for awhile.
If it would help anyone, I could post the results, later today.
Reply
#5
I want to report, that after going with the latest Development Build and going with Flatout's suggestion via OpenGL Hardware... we got everything looking good upressed and FXAA enabled is the best I can get. I'm satisfied. All sprites with the new options are phenomenal!

I'll post screens soon. I also want to add in I'm rocking 8x native now. No slowdowns from my rig.
Reply




Users browsing this thread: 1 Guest(s)