Thread Rating:
  • 0 Vote(s) - 0 Average
  • 1
  • 2
  • 3
  • 4
  • 5
Trying to use mouse as analog
#1
Hello everybody!

Game: Metropolismania 2
Plugin: Lilypad 0.11.0
Problem:

---------
      I managed to set up the keyboard and the game was working smoothly (other than the speed up, speed down issues which i care little about) ... But then I finished a level. When you finish a level in this game, it adds the "move to next level" option into the wheel menu. Diagonal to the lower left. I can normally do diagonals by just pressing 2 keys at once. 
      It seemed to work fine, but no matter what I do, I cannot reach the next level button. I'm assuming it's some sort of wheel control (analog stick) that was made to access it... So, my next hope was to set up mouse (as I do not have a controller of any sort... except maybe an old joystick.) However, mouse control doesn't work at all for me.
---------

I have:

Enabled every API setting for mouse

Clicked the "mouse" option under "pad 1" and it proceeded to do nothing. Well, it would allow me to click and input... and whatever I inputed showed up as a mouse option. Like this: 

DX Mouse             X-axis -       Mouse

And I tried doing that to all of the options I would need. Did not work in game.

Manually selected "L stick" "Up stick" blah blah for all of them (it did recognize the axis +, axis - stuff)

Nothing has worked. I tried scrolling the forums and googling, but I find other people solving it where I can not.

If this game is just a hopeless game, I am willing to accept that. I just want to know if I should give up or if there is something I can do.

Thank you.
Reply

Sponsored links

#2
Solution
First try vJoy (http://vjoystick.sourceforge.net/site/) to see if it will allow you to easily map a keyboard as a joystick giving you diagonal controls.

If that fails then the more complicated way is to use xbox360kb.ini to emulate a 360 controller with the keyboard and AutoHotKey Universal control remapper to fix it to work with your game. Kinda a pain but more flexible then vJoy is.

Use this (http://forum.arcadecontrols.com/index.php?topic=96377.0) to allow a keyboard to be mapped as an Xbox360 contoller
then use this (https://www.autohotkey.com/boards/viewto...19&t=12249)

GL
Reply
#3
Thank you so much! I just tried the first vJoy thingy and I wasn't really sure how to get it to work with lilypad, but it seemed to just work! I can now continue the game!  Biggrin
Reply
#4
Update: Yes, somehow it worked the first time, but I finished that level and moved onto the next on a separate day... It is doing the same thing again. I attempted to look into the second option, but with no direction or prior knowledge about any of this software, I am completely lost. I will try just reinstalling vJoy again, but I doubt anything change simply after a reboot or two.
Reply
#5
FINAL SOLUTION:

After messing around with this stuff for a while, I went into the Lilypad configuration...

Under "Configure Binding" after you have mapped a key, there is an option to select the sensitivity. Simply map an extra key to the direction you need and cut the sensitivity from 1 to 0.5... Tada! Half the pressure on the analog stick, and the selection is more precise!
Reply




Users browsing this thread: 1 Guest(s)